Solved ld-elf.so.1: Shared object "libicuuc.so.69" not found, required by "libtepl-6.so.0"

ziomario

Aspiring Daemon

Reaction score: 74
Messages: 763

Yesterday I did a "pkg upgrade" and after that I found that some applications had some missing libraries. One of them is gedit. So I've reinstalled it,but the error is not gone :

Code:
root@marietto:/usr/home/marietto # pkg install gedit

Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
The following 1 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
gedit: 40.1

Number of packages to be installed: 1

The process will require 13 MiB more space.
2 MiB to be downloaded.

Proceed with this action? [y/N]: y
[1/1] Fetching gedit-40.1.pkg: 100%    2 MiB   2.0MB/s    00:01
Checking integrity... done (0 conflicting)
[1/1] Installing gedit-40.1...
[1/1] Extracting gedit-40.1: 100%
Generating GTK icon cache for /usr/local/share/icons/hicolor

root@marietto:/usr/home/marietto # gedit
ld-elf.so.1: Shared object "libicuuc.so.69" not found, required by "libtepl-6.so.0"

different packages are affected :

Code:
root@marietto:/usr/home/marietto # remmina
ld-elf.so.1: Shared object "libicuuc.so.69" not found, required by "libvte-2.91.so.0"

marietto@marietto:/usr/home/marietto $ remmina
ld-elf.so.1: Shared object "libicuuc.so.69" not found, required by "libvte-2.91.so.0"
 
OP
ziomario

ziomario

Aspiring Daemon

Reaction score: 74
Messages: 763

I did another "pkg upgrade" and it has upgraded a lot of new packages (not offered yesterday) and this has fixed the previous error.
 
Top