Solved Laptop too hot and turns off

Staffan Mattsson


Reaction score: 3
Messages: 50

I've recently installed freebsd on my Compaq-Cq laptop, and with help from this forum I got xfce working. While doing my causal webbrowsing though, the system shutsdown because the cpu gets too hot.
This didnt happen when I was running Ubuntu mate.

I have however upgrade the CPU myself from a AMD sempron to an AMD Turion dual core. But like I said, this new CPU ran fine in Ubuntu for over a month.

Any ideas? This is really a dealbreaker for me.


Well-Known Member

Reaction score: 218
Messages: 337

Makes me wonder why this isnt always turned on.
On FreeBSD you don't find non-essentials services turned on by default. FreeBSD is mainly (but not only ;)) a server oriented OS, so you could want always maximum performance and powerd(8) is not enabled. On laptops (and desktops as well), power consumption (and heat produced) could be significant however (like in your case). Oh, I was forgetting: it's always easier enabling what you want than disabling what you don't! :)


Son of Beastie

Reaction score: 2,407
Messages: 2,933

There are powerd flags to use when your laptop is plugged in or using the battery:

powerd_flags="-a hiadaptive -b adaptive"
hiadaptive uses more power, for when it's plugged in.

I had been using them backwards for years till micheal_hackson recently made me aware of it.
Staffan Mattsson

Staffan Mattsson


Reaction score: 3
Messages: 50

Haha not easy to get it right lebarondemerd. :)

Looking from the outside though, the freebsd community would be healthier if it focused a little more on the desktop. More people would get involved of which at least some could move on to server developement. But thats just an outsiders reflexion.

Me myself run it for fun now just because there are few peolpe running it, and well see when I get tired of it. Yesterday I got the letters å ä and ö working...
It makes me feel cool somewhat. :)