Krunner slow to start/appear

guidok

Member

Reaction score: 13
Messages: 36

Liking KDE5 very much on my Thinkpad T480. However there is one thing that bothers me. Pressing Alt-Space to bring the krunner window up is slow; it consistently takes anywhere between 1 and 2 secs for it to appear. This causes the first couple of keystrokes to go to whatever window currently has focus, instead of going into krunner as a search query.

Initially I thought that KDE5 would not keep krunner running, causing it to be exec'd each and every time. Though a simple ps aux | grep krunner shows that it is being kept running. Then I thought that the large number of plugins might be the culprit. Hence I have disabled all of them except for the Applications one. (I primarily use krunner as an app launcher). No change; it still takes between 1 and 2 secs.

Is this normal for krunner, or is there a way to make it appear virtually instantaneously?

Operating System: FreeBSD 12.0
KDE Plasma Version: 5.18.4
KDE Frameworks Version: 5.68.0
Qt Version: 5.13.2
Kernel Version: 12.1-RELEASE-p3
OS Type: 64-bit
Memory: 31,9 GiB of RAM

Edit: spelling
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 10,739
Messages: 36,540

Operating System: FreeBSD 12.0
{...}
Kernel Version: 12.1-RELEASE-p3
These don't add up. Make sure your userland is in sync with your kernel.
 
OP
guidok

guidok

Member

Reaction score: 13
Messages: 36

That's probably a KDE5 thingy. freebsd-version -kru shows them to be all in sync.

Code:
$ freebsd-version -kru
12.1-RELEASE-p3
12.1-RELEASE-p3
12.1-RELEASE-p3
 
Top