Kmail using 100% cpu

rawthey

Member

Reaction score: 6
Messages: 53

Today kmail has started to consume 100% cpu and is totally unresponsive to mouse clicks. As far as I'm aware there's been no recent changes to any system settings.
Code:
last pid:  2846;  load averages:  0.70,  0.36,  0.27     up 0+01:51:55  14:26:04
161 processes: 2 running, 158 sleeping, 1 zombie
CPU 0: 14.6% user,  0.0% nice,  0.0% system,  0.0% interrupt, 85.4% idle
CPU 1: 29.5% user,  0.0% nice,  0.4% system,  0.0% interrupt, 70.1% idle
CPU 2: 34.1% user,  0.0% nice,  0.0% system,  0.4% interrupt, 65.5% idle
CPU 3: 23.0% user,  0.0% nice,  0.4% system,  0.0% interrupt, 76.6% idle
Mem: 1224M Active, 1398M Inact, 11M Laundry, 9118M Wired, 40K Buf, 3961M Free
ARC: 7362M Total, 2127M MFU, 5103M MRU, 7744K Anon, 31M Header, 94M Other
     6514M Compressed, 8733M Uncompressed, 1.34:1 Ratio
Swap: 8192M Total, 8192M Free

  PID USERNAME     THR PRI NICE   SIZE    RES STATE   C   TIME    WCPU COMMAND
 2806 mike          27 101    0   559M   284M CPU1    1   0:32 100.22% kmail
 2831 mike          54  23    0  7827M   506M select  3   0:06   0.39% firefox
 2561 root           2  20    0 82316K 60476K select  1   0:03   0.18% Xorg
 2839 mike          21  20    0  1296M   135M select  0   0:00   0.16% firefox
 2791 mike           4  20    0   143M 81500K select  2   0:00   0.16% konsole
 2638 mike           6  20    0   222M   102M select  0   0:01   0.09% kwin_x11
 2819 mike           1  20    0  7920K  4460K CPU3    3   0:00   0.06% top
 2619 mike           7  20    0   159M 85948K select  0   0:01   0.05% kdeinit5
  736 root           1  20    0  6604K  2404K select  1   0:top 02   0.04% moused
 1130 haldaemon      2  20    0 16460K  9800K select  0   0:04   0.02% hald
  362 root           1  20    0  9180K  5164K select  0   0:02   0.02% devd
 2843 mike           3  20    0 19452K  8840K select  1   0:00   0.01% gvfs-hal-
Although kmail had only been running for a short time in the above example I have previously left it running for about an hour when it was cpu bound for the whole time.

FreeBSD 11.2-RELEASE-p7
kmail-18.12.1_1
akonadi-18.12.1_1

I've tried clearing the akonadi cache but that made no difference.

Any suggestions how to go about fixing this problem?
 
Top