kitty and linux opera are unusable

My observation is about the above two packages.

When I open Opera the CPU goes to 100% and it doesn't even open after a long wait.
kitty does open how I remember it but also uses extremely high CPU and is abnormally slow.

I think these two packages are currently unusable. I'd like to report it to the package maintainer, but first I'd like to ask what your experiences are with these packages?

It may also be that the problem is limited to my configuration. I would like to know that in advance.
Last edited by a moderator:
If something simply doesn't start, I'd use truss on it (with -f, as it's likely to invoke other binaries), and check what's doing (or stopping at). Linux syscalls should be pretty much translated in truss.
I can say running kitty in an xorgxrdp desktop via xrdp it does not use 100% on launch and works without issue.
Also, maybe check with the port maintainer to get it updated because I'm sure that might be the first question from the developer.
For you as information:
I had the problem on FreeBSD 12.2 (or 12.3)
Meanwhile I'm on 13.1

The reason why I wanted to test kitty was because in all the other terminals I tried I had some kind of specific problem(s). Sometimes copy paste didn't work, sometimes I couldn't get the font or characters in another language to work correctly, and so on.

However, in recent months I have been using mate-terminal and I am actually quite satisfied with it. The only issue is that it sometimes takes a fraction longer to open, but that's very sporadic and the delay isn't that long either. And 99.99% of the time it opens instantly.

I see that kitty uses a lot of Python and I'm not a fan of slow Python code, so I don't see any reason to test whether it still has a problem or not. If you really wanted to know if it works now I'd be happy to reinstall it and test it. But I'm never going to use it as long as mate-terminal works as well as it currently does.