Keyboard with additional keys for FreeBSD

abishai

Aspiring Daemon

Reaction score: 185
Messages: 767

I have a Logitech G15 keyboard and it has additional key block (https://secure.logitech.com/assets/28553/28553.png). The problem is they are not uhid() compatible, so usbhidctl() is not detecting them. Logitech is not shipping drivers for FreeBSD and even with Google help I found no clue how to switch them on. I think it's a dead end.
I thought it would be nice if some other keyboard has hid-compilant or supported by FreeBSD keys block to assign some useful actions on it, like virtual desktop switching. Maybe some one has such keyboard and shares it's model.
 

jrm@

Daemon
Developer

Reaction score: 490
Messages: 1,215

abishai said:
The problem is they are not uhid() compatible, so usbhidctl() is not detecting them.
Does that mean x11/xev won't detect them? If they are detected, you could use something like x11/xbindkeys to make them do something useful. I don't really know what I'm talking about here. I just know that this worked for me with some keys on my laptop. For example, I put
Code:
"/usr/sbin/mixer vol -5  pcm -5"
  XF86AudioLowerVolume
"/usr/sbin/mixer vol +5  pcm +5"
  XF86AudioRaiseVolume
in ~/.xbindkeysrc to get the volume keys to work.
 

tetragir

Member

Reaction score: 16
Messages: 82

I've also tried sysutils/uhidd, but it performed poorly. True, I could configure the media keys on my keyboard, but the mouse started acting weird. The cursor has just stopped, or slowed down, and also the click only happened, if I have moved the cursor right after the click. Is there any option, I could turn on, that prevents uhidd to do anything with my mouse, but only recognize and use my keyboard?
Thank you very much.
 

protocelt

Daemon

Reaction score: 414
Messages: 1,253

I've also tried sysutils/uhidd, but it performed poorly. True, I could configure the media keys on my keyboard, but the mouse started acting weird. The cursor has just stopped, or slowed down, and also the click only happened, if I have moved the cursor right after the click. Is there any option, I could turn on, that prevents uhidd to do anything with my mouse, but only recognize and use my keyboard?
Thank you very much.
Take a look at the uhidd(8) man page. In short you'll want to run uhidd with the -o flag. I do notice there is no maintainer for that port though so I'm not sure how long it will work unless it's updated/picked up by a new maintainer.

Additionally you can check out uhidvkbdd which I am successfully using right now for keyboard multimedia keys. It's not in the ports tree however. Installation details are at the website.
 
Top