keyboard us_intl with dead keys

mururoa

Active Member

Thanks: 1
Messages: 124

#1
Hello,

I can't manage to configure keyboard layout properly. With any choice I tested I can't manage to use dead keys. It means I can't produce accentuated letters. I get accent and then letter instead of accentuated letters. Like 'e 'a ^e instead of é á ê.
I don't want to use any compose key but just usual US-Intl dead key (' " ^ ` ...). So far in Linux, selecting keyboard US_intl with dead keys just works but it's not the same here. Not functioning in Konsole either but that's not a real problem. Locale is en_US.UTF-8

What's the trick?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 6,232
Messages: 27,223

#2
I can't test this remotely but have you looked at the keyboard maps in /usr/share/syscons/keymaps? I'm not sure if it's the one with deadkeys but have you tried us.iso.acc.kbd?
 

meine

Member

Thanks: 7
Messages: 32

#3
I had the same problem with accents in Dutch -- é, ï, ë, etc.

The solution is described in the FreeBSD Handbook, par. 5.4.7.1 Keyboard Layout. There is also a link to a list with all layouts and parametres.

I just followed the book and it works well in a GUI environment. Since it is a config file for X11, it doesn't work in TTY console directly.

It is possible that /etc/login.conf also needs settings to use the ISO-8859-15 character set, where the accent characters are defined. That is described in the Handbook par 22.2 Using Localization.
 
Top