Kernel trap 12 with interrupts disabled when booting from UEFI how to reduce resolution?

Hellow i am from brazil. Sorry if i have a bad english.

I am trying to migrate from Linux to FreeBSD, to that i downloaded a distro named ghostbsd.

Because the error is in the freebsd kernel i am contacting you directly (i know its a hardware problem, but other operating systems know about that and booting normally).

I am only able to install freebsd in legacy mode configured bios machines (i tried 3 different machines), every machine that i try to run a version of freebsd with UEFI i got something like this:
kernel trap 12 with interrupts disabled

Fatal trap 12: page fault while in kernel mode
cpuid = 0; apic id = 0​

Well, someone says in a topic that found was able to boot when reducing the resolution, the thing is i am not able to reduce the resolution, the ghostbsd is using grub-uefi to boot from the stick, so i am trying the following command lines on kernel:

kern.vt.fb.default_mode="640x480" but the resolution wont changed.

And many others, so how to force the change of this resolution? Or is there another trick to try the boot to happen..

If the problem is with memory, how to reduce the size of memory recognized by freebsd like i do in linux : linux mem=1024M (for example)
Não sou um veterano mas te dou as boas vindas a comunidade de BSDs em geral, e desejo boa sorte sobre a resolução do seu problema.
Tente perguntar na lista de emails freebsd-hackers, talvez se não encontrar a resposta aqui lá encontre. Enfim, como o problema aparenta ser apenas num modo especifico, a instalação no modo UEFI é realmente necessaria? Outros SOs funcionam no modo UEFI? Tentou baixar a imagem mais de uma vez e/ou testou o checksum da mesma? Boa sorte

Try asking on the freebsd-hackers mailing list, you may find your answer there. So, as the problem seems UEFI specific, installing as UEFI is really necessary? Do any other OSes work on UEFI mode? Did you tried downloading the image again and/or testing its checksum? Good luck