Solved Kernel panic or something like that.

helmet1080

Member

Reaction score: 3
Messages: 49

The system just crashed unspectedly. Although the system kept information somewhere on the system.
Does it happen often with KDE? I have installed the system like 8 times with KDE, xorg, ati drivers, sddm, hal, etc. I want to learn the system but the system crashes, and that's not a good thing.

I run FreeBSD-12.0-RELEASE.

Thank you.
 

Nicola Mingotti

Well-Known Member

Reaction score: 141
Messages: 370

if you are not willing to fight with hardware issues i strongly reccomend you start your journey installing FreeBSD in a virtual machine. When you will be comfortable enough, move to metal.

I use FreeBSD all day, all days, in a virtualbox vm, running in the institute Window10 laptop. It works well.
 

Vull

Well-Known Member

Reaction score: 119
Messages: 285

I run KDE for days on end and it never crashes, and have been doing so off and on for several months now. I have 3GB RAM, i386, ~ 6GB swap, on a bare metal machine which is over 12 years old, although the hard drive is only a few years old. I suggest you might try disabling File Search in System Settings, and to put these two lines in /etc/sysctl.conf if they aren't already in there (as recommended by a pkg-message during the install):

net.local.stream.recvspace=65536
net.local.stream.sendspace=65536
 
OP
OP
helmet1080

helmet1080

Member

Reaction score: 3
Messages: 49

I run KDE for days on end and it never crashes, and have been doing so off and on for several months now. I have 3GB RAM, i386, ~ 6GB swap, on a bare metal machine which is over 12 years old, although the hard drive is only a few years old. I suggest you might try disabling File Search in System Settings, and to put these two lines in /etc/sysctl.conf if they aren't already in there (as recommended by a pkg-message during the install):

net.local.stream.recvspace=65536
net.local.stream.sendspace=65536
I saw the message and I didn't do anything. Last night I saw a video on youtube on installing FreeBSD with KDE5, and last configuration was this two configuration lines. I wrote them on the sysctl.conf file.
Thank you. And I hope everything is OK now.
 

Vull

Well-Known Member

Reaction score: 119
Messages: 285

I saw the message and I didn't do anything. Last night I saw a video on youtube on installing FreeBSD with KDE5, and last configuration was this two configuration lines. I wrote them on the sysctl.conf file.
Thank you. And I hope everything is OK now.
You're welcome and thanks for replying. I hope it works for you. I also turned off the "File Search" in System Settings because it was using a lot of memory, making my system thrash and run slowly. If you still have problems you might want to uncheck these two checkboxes in System Settings:
Code:
  Search
    File search
      Untick "Also index file content"
      Untick "Enable file search"
On KDE this is also called "baloo" file search. Baloo might work better on systems with a lot of memory, but there have still been complaints from some people who had a lot more memory than I do. It also might work better in the more recent versions, but I haven't tried it recently, since I really don't need it anyway.
 
OP
OP
helmet1080

helmet1080

Member

Reaction score: 3
Messages: 49

if you are not willing to fight with hardware issues i strongly reccomend you start your journey installing FreeBSD in a virtual machine. When you will be comfortable enough, move to metal.

I use FreeBSD all day, all days, in a virtualbox vm, running in the institute Window10 laptop. It works well.
I push hard to solve problems, but the last resource seems to be the only driver that support my video card that wasn't working even though I compiled it. Kernel panic. I ran it on virtual box first and second day, and I installed it on the desktop machine those days as well.
It seems that this configuration is gonna save me energy.

net.local.stream.recvspace=65536
net.local.stream.sendspace=65536


It seems the kernel need them.

Hope with this, this doesn't crash anymore.
Thank you for the advice.
 
OP
OP
helmet1080

helmet1080

Member

Reaction score: 3
Messages: 49

You're welcome and thanks for replying. I hope it works for you. I also turned off the "File Search" in System Settings because it was using a lot of memory, making my system thrash and run slowly. If you still have problems you might want to uncheck these two checkboxes in System Settings:
Code:
  Search
    File search
      Untick "Also index file content"
      Untick "Enable file search"
On KDE this is also called "baloo" file search. Baloo might work better on systems with a lot of memory, but there have still been complaints from some people who had a lot more memory than I do. It also might work better in the more recent versions, but I haven't tried it recently, since I really don't need it anyway.
The desktop machine running FreeBSD has 5gb of memory. I'd don't mind to put some more memory to have all the features working. I haven't used the system settings though.
Another thing that is happening, is that the terminal doesn't save tweaks. I restart and everything is gone. Does this happen to you?
 
OP
OP
helmet1080

helmet1080

Member

Reaction score: 3
Messages: 49

I run KDE for days on end and it never crashes, and have been doing so off and on for several months now. I have 3GB RAM, i386, ~ 6GB swap, on a bare metal machine which is over 12 years old, although the hard drive is only a few years old. I suggest you might try disabling File Search in System Settings, and to put these two lines in /etc/sysctl.conf if they aren't already in there (as recommended by a pkg-message during the install):

net.local.stream.recvspace=65536
net.local.stream.sendspace=65536
It crashed two times now with an interval of minutes between this two. What should I do next?
 

Vull

Well-Known Member

Reaction score: 119
Messages: 285

The desktop machine running FreeBSD has 5gb of memory. I'd don't mind to put some more memory to have all the features working. I haven't used the system settings though.
Another thing that is happening, is that the terminal doesn't save tweaks. I restart and everything is gone. Does this happen to you?
There is one setting that I've been unable to apply successfully. It's the Power Management setting that tells it to not turn the screen off after a period of time. It seems to apply it after I untick the checkbox, but then when I go back and look at that setting again, it has mysteriously ticked itself again. I wonder if it might be because the power management firmware on this computer is old and buggy. All the other settings seem to work okay.
It crashed two times now with an interval of minutes between this two. What should I do next?
It's hard to guess what the problem might be without knowing more about your setup.

1. Do you have a dedicated swap partition? One person reported having similar problems which went away after he reinstalled FreeBSD with a dedicated swap partition. I'll try to find that thread.

2. What version of KDE are you installing?

3. Are you using a command like pkg install kde5 to install it?

4. I don't use any ati drivers at all. What are the ati drivers you install, and how do you install them?
 
OP
OP
helmet1080

helmet1080

Member

Reaction score: 3
Messages: 49

There is one setting that I've been unable to apply successfully. It's the Power Management setting that tells it to not turn the screen off after a period of time. It seems to apply it after I untick the checkbox, but then when I go back and look at that setting again, it has mysteriously ticked itself again. I wonder if it might be because the power management firmware on this computer is old and buggy. All the other settings seem to work okay.
It's hard to guess what the problem might be without knowing more about your setup.

1. Do you have a dedicated swap partition? One person reported having similar problems which went away after he reinstalled FreeBSD with a dedicated swap partition. I'll try to find that thread.

2. What version of KDE are you installing?

3. Are you using a command like pkg install kde5 to install it?

4. I don't use any ati drivers at all. What are the ati drivers you install, and how do you install them?
I installed xorg, hal, kde5, sddm plasma5-sddm-kcm, and sddm-freebsd-black-theme, all from the command line, and yes, with pkg. I installed the driver from port, and I enable the module on the rc.conf file.

Please check out this thread: https://forums.freebsd.org/threads/swap_pager_getswapspace-failed.61290/

I also forgot about the procfs system which is recommended on kde.org. You should install it by adding this line to your /etc/fstab file and rebooting:
Code:
proc            /proc           procfs  rw      0       0
I wrote the configuration on file /etc/fstab.
It's the driver the problem. The message when rebooting says "radeon". I couldn't know the reason why the system doesn't dump the errors messages the in the /var/crash folder. It's just empty, with a file called minifree something that says 2048. Now I'm running KDE plasma from UbuntuMate. Later I'm gonna try FreeBSD again but with a Nvidia video card. Thank you for the reply.
 

Vull

Well-Known Member

Reaction score: 119
Messages: 285

It is possible that I need a dedicated partition for proc? The diskviewer from kde showed that /proc full.
No. There is no partition needed for procfs. The procfs file system is not mounted on a disk drive device like a normal file system is, but rather, it's a "ramdisk," which is a structure in memory which looks like a regular file system. I don't have access to my FreeBSD system right now, but if I remember correctly, it's normal for procfs, devfs, and other ramdisk type file systems to show 100% usage.

I've never used either the Nvidea or Radeon graphics software, so I don't really know much about them. It might be possible to get the graphics support you want by installing the drm-kmod package or port, instead of the radeon port, but it requires further configuration and I don't know the details.

It isn't necessary to install hal yourself, because the kde5 package will install it as one of its dependency requirements. I'd let the pkg program do it. That way you'll be more certain to get the right version.

Sorry that this first try didn't work out so well. I also had problems the first time I tried to install KDE and many people do, so please don't be discouraged from trying again when you have time. I would also recommend postponing the installation of the plasma5-sddm-kcm package and the black theme until after you're sure that the system is running correctly. You can always install them later.
 

CrowdedNewt

Member

Reaction score: 2
Messages: 22

The system just crashed unspectedly. Although the system kept information somewhere on the system.
Does it happen often with KDE? I have installed the system like 8 times with KDE, xorg, ati drivers, sddm, hal, etc. I want to learn the system but the system crashes, and that's not a good thing.

I run FreeBSD-12.0-RELEASE.

Thank you.
I have the same issue. I run kde5 and use radeonkms, and I get random kernel panics when using KDE 5... I was excited that an actual modern DE was on freebsd too but oh well
 

CrowdedNewt

Member

Reaction score: 2
Messages: 22

I switched to a different DE (windowmaker) and have not had any more kernel panics.. I think it is just an issue with kde, you should try another DE.
 
OP
OP
helmet1080

helmet1080

Member

Reaction score: 3
Messages: 49

I switched to a different DE (windowmaker) and have not had any more kernel panics.. I think it is just an issue with kde, you should try another DE.
Sure, why not. Though I love kde Plasma, so I need to get a Nvidia card. What is that about the windowmaker? What windowmaker do you recommend? And thanks for the reply.
 

AlexanderProphet

Active Member

Reaction score: 31
Messages: 145

KDE5 on my ThinkPad causes a crash/reboot about once every day or two.
I was told by someone on this forum it must be a hardware problem but having read various other people's experiences I'm increasingly sceptical of that.
Think I'll reinstall Kubuntu and just use FreeBSD in Virtualbox.
 
OP
OP
helmet1080

helmet1080

Member

Reaction score: 3
Messages: 49

KDE5 on my ThinkPad causes a crash/reboot about once every day or two.
I was told by someone on this forum it must be a hardware problem but having read various other people's experiences I'm increasingly sceptical of that.
Think I'll reinstall Kubuntu and just use FreeBSD in Virtualbox.
Yeah, I'm gonna use Virtualbox for now. Maybe later when I get a Nvidia video card, I try it on the desktop machine again.
 

CrowdedNewt

Member

Reaction score: 2
Messages: 22

Sure, why not. Though I love kde Plasma, so I need to get a Nvidia card. What is that about the windowmaker? What windowmaker do you recommend? And thanks for the reply.
I don't reccomend windowmaker.
But if KDE5 is causing these crashes then it might do to try another DE, xfce4 is a good one.
 

Vull

Well-Known Member

Reaction score: 119
Messages: 285

I had no luck either last fall when I was trying to configure a Radeon graphics driver for my Acer Aspire A315-21-95KF laptop, but once I settled on using the scfb driver instead, I had no problems with running either kde4 or kde5. However the colors were really bland, cold, and muted, and so to make a long story short I ultimately got rid of that laptop, and will probably never buy any AMD hardware again, since I always seem to get lemons from them. Nowadays I run KDE/Plasma-5-plasma without any problems, but I only use it on an old machine with an obsolete Intel graphics card, and no special drivers or configuration whatsoever. The colors are warm and I get decent resolution, using an old HP monitor with nothing but the graphics drivers that Xorg assigns to me automatically on the first try, all of which is fine and plenty good enough for my purposes. I don't play any games but can still watch videos using vlc after tweaking the vlc settings just a little.
 

CrowdedNewt

Member

Reaction score: 2
Messages: 22

I had no luck either last fall when I was trying to configure a Radeon graphics driver for my Acer Aspire A315-21-95KF laptop, but once I settled on using the scfb driver instead, I had no problems with running either kde4 or kde5. However the colors were really bland, cold, and muted, and so to make a long story short I ultimately got rid of that laptop, and will probably never buy any AMD hardware again, since I always seem to get lemons from them. Nowadays I run KDE/Plasma-5-plasma without any problems, but I only use it on an old machine with an obsolete Intel graphics card, and no special drivers or configuration whatsoever. The colors are warm and I get decent resolution, using an old HP monitor with nothing but the graphics drivers that Xorg assigns to me automatically on the first try, all of which is fine and plenty good enough for my purposes. I don't play any games but can still watch videos using vlc after tweaking the vlc settings just a little.
Max comfy.
 

Vull

Well-Known Member

Reaction score: 119
Messages: 285

Max comfy.
Acceptably comfy for a development machine which is mainly used just to test things out, as opposed to being a multimedia entertainment and gaming system, like I think the Acer Aspire was designed to be. So I let it go free, restoring its Windows 10 partition to use the full 1TB drive and OEM-encumbered hardware for its intended Windows 10 destiny, with somebody else. :) Total bliss. All happy.
 
OP
OP
helmet1080

helmet1080

Member

Reaction score: 3
Messages: 49

Freebsd12 radeon driver is unstable. Use legacy drm-kmod.


I installed that drm-kmod from ports and it worked, but it crashes. I wonder what is the partition configuration while installing for a 120GB SSD Disk. I installed all with one partition, root ( / ). I have 5GB RAM, and I don't know if 7.5GB swap it's ok. Although It doesn't touch it. I read that the system it's not using the all the RAM and that's why is crashes. Something like that.
The system wasn't saving the data why it crashes in /var/crash, so I have to find out why.


A comment on this location says about the RAM:


Oook... and I have no clue where to start from, hehe :)

I will give "sysctl vm.defer_swapspace_pageouts=1" a try and will see if it will change anything...
I had the same problem on my FreeBSD 11-RELEASE (8 G of RAM) when I am building ports with Synth and I did try your settings and it works :).
 
Top