Kernel panic booting without kern.smp.disabled=1 on QNAP TVS-873 (AMD RX-421BD)

derzahla

New Member

Reaction score: 1
Messages: 4

Hi all, Id love to get FreeBSD up running fully on my QNAP hardware but I'm running into some issues with SMP. I've searched high and low and found some similar situations but nothing proposed worked for me(other than disabling SMP completely). I have replicated this issue on the latest FreeNAS, TrueNAS Core, FreeBSD-13 nightly and also FreeBSD 10.4.

Here is the console while booting without SMP disabled:

qnapTVS-873FreeNAS.jpeg


I have tried setting some other boot options such as hw.apic.0-3.disabled=1, but the only thing that allows me to boot is completely disabling SMP. From my understanding, these issues are often related to buggy BIOS. This NAS has a very old(2016) and very options limited AMI bios which QNAP does not provide an update for. Does anyone have any other ideas for options that may work around this mess and give me a functional and stable system running FreeBSD? I have also tried setting kern.smp.disabled to 0 with sysctl after booting to see if that might work. Apparently though that setting can only be changed at boot? Thank you for your time and let me know if you require further information.
 
OP
D

derzahla

New Member

Reaction score: 1
Messages: 4

Thanks for the reply. I did read that post, and just about every other one I could find. It isn't fixed for my hardware though it seems. As I stated I tried the latest FreeBSD-Current nightly from a few days ago and the problem is still present. Im hoping there is some workaround but everything I've tried (enabling kern.smp via sysctl after boot, setting hw.pci.alloc_bar=1, etc) doesn't help. I even tried FreeBSD 10.4, because I read that starting in FreeBSD 11 the kernal started using EARLY_AP_STARTUP, which might be what is causing my problems. No go with 10.4 either. Ive heard brief mentions about adjusting the timing of the CPUs being initialized, but I'm not sure where to start there. Any guidance would be much appreciated!
 
OP
D

derzahla

New Member

Reaction score: 1
Messages: 4

OP
D

derzahla

New Member

Reaction score: 1
Messages: 4

Update: I opened a case with QNAP because there was no BIOS updates for my device available on their site and the current version was from 2016. I updated to the latest BIOS and also tried to boot stock FBSD 12.1. Same issue, unless i boot safe mode or set kern.smp.disabled=1
 

Tomlawesome

New Member

Reaction score: 1
Messages: 3

Update: I opened a case with QNAP because there was no BIOS updates for my device available on their site and the current version was from 2016. I updated to the latest BIOS and also tried to boot stock FBSD 12.1. Same issue, unless i boot safe mode or set kern.smp.disabled=1
Don't mean to necro the thread... but it's not really that long ago, and I too am having the same issue, but with different hardware. Did you find a resolution?
 
Top