KDE5 Plasma does not store my custom settings.

jeltoesolnce

Member


Messages: 23

Hello. If I change mouse settings, KDE Plasma does not save them. I get default settings after exit him.

I use sddm display manager, FreeBSD 12.0-RELEASE.
 

T-Daemon

Active Member

Reaction score: 84
Messages: 249

If I’m not mistaken, the mouse configuration for kde plasma is saved in ~/.config/kdeglobals, section [KDE]. Check if the custom mouse settings are registered in that file after setting them in “System Settings”, log out, log in, check kdeglobals again. If the settings are the custom mouse settings some other kdeglobals file may supersede the users kdeglobals file. Check the users home directory for other kdeglobals files and if they contain any mouse settings.

If you have eliminated possible other configuration files, and the problem persists, you can try setting the KDEHOME=‘~/.config’ environment variable in the users log in shell configuration file (depending of the shell: .shrc, .cshrc, .tcshrc, .bashrc).

If none of the suggestions resolves the problem try the custom configuration of the mouse in a fresh created user account.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,266
Messages: 29,700

Also check the permissions and ownership of those files. If you used su(1) or sudo(8) to start something those files may have been created by root. Which means your 'normal' user account can't modify them any more. A chown(8) might be needed in order to set the owner to your user account.
 
OP
OP
jeltoesolnce

jeltoesolnce

Member


Messages: 23

Hello, colleagues, thank you.

I did it, and what I have: if I set lefthanded mouse setting, I see it in settings in ~/.config/kcminputrc:

Rich (BB code):
[Mouse]
Acceleration=2
AccelerationProfile=
MouseButtonMapping=LeftHanded
ReverseScrollPolarity=false
Threshold=2
But mouse lose the settings if I logout and login again. I created new user and checked mouse behavior there - all the same. I think it is a bug, and I'll report.
 

helmet1080

Member

Reaction score: 3
Messages: 49

Me too. I change the background to white on the kde terminal and reboot, the change is gone. weird.
 
Top