KDE5 and sddm not starting (nvidia drivers in use)

youngunix

Active Member

Reaction score: 40
Messages: 228

I have a freshly 12.1-RELEASE installed and trying to run KDE5. I am using the latest nvidia drivers but sddm doesn't seem to load. if I run service sddm onstart I get a blank screen with a frozen cursor. If I run sddm-greeter --test-mode I get could not connect to display, could not load the QT platform plugin "xcb" in "" even though it was found. I have tried reinstalling sddm and qt5-gui to no avail.
 

mickey

Aspiring Daemon

Reaction score: 293
Messages: 731

Have you tried startx before going to full blown KDE? Have you checked /var/log/Xorg.0.log for any potential problems starting X.org?
 

Dogers

Member

Reaction score: 13
Messages: 43

Greetings.

I have the same issue, it seems to affect sddm, gdm, I even got freeze with gnome-session. The only workaround I have found is to comment out the driver line in /etc/rc.conf. And for now the only solution I got for using my driver is to work on another desktop environment via Slim, I am currently under MATE until the problem gets fixed. Execept that for me, the problem appears just after a pkg upgrade. It is probably linked with driver or xorg. Here is the topic I report the problem in my case, maybe you could find something useful or obtain more details :

 
OP
youngunix

youngunix

Active Member

Reaction score: 40
Messages: 228

Have you tried startx before going to full blown KDE? Have you checked /var/log/Xorg.0.log for any potential problems starting X.org?
I did, and the results are the same. The log file you mentioned doesn't contain any errors, it seems like KDE5 and sddm are broken in FreeBSD perhaps I should try some other DE.
 

mickey

Aspiring Daemon

Reaction score: 293
Messages: 731

I did, and the results are the same. The log file you mentioned doesn't contain any errors, it seems like KDE5 and sddm are broken in FreeBSD perhaps I should try some other DE.
So what happens when you use startx? Do you get a black screen with frozen cursor, or do you get three xterms and it's working? What version of x11-servers/xorg-server is installed? Did you install from packages or ports and if packages which repository (quarterly/latest)? I highly doubt that KDE or sddm are broken as I have two installations (one using ports, one using latest packages) where they work just fine.
 
OP
youngunix

youngunix

Active Member

Reaction score: 40
Messages: 228

So what happens when you use startx? Do you get a black screen with frozen cursor, or do you get three xterms and it's working? What version of x11-servers/xorg-server is installed? Did you install from packages or ports and if packages which repository (quarterly/latest)? I highly doubt that KDE or sddm are broken as I have two installations (one using ports, one using latest packages) where they work just fine.
startx used to give blank screen with frozen cursor but now gives an error the XKEYBOARD keymap compiler (xkbcomp) reports: > Internal error: could not resolve keysym XF86FullScreen - Error from xbcomp are fatal to the X server.
I am using quarterly, packages only and xorg 7.7.3.
 

Menelkir

Member

Reaction score: 58
Messages: 83

I had this particular configuration in my desktop, and yes, it fails. So my "fix" was make a configuration that applies only to video and put on /usr/local/etc/X11/xorg.conf.d/. I'll paste mine, but make sure you make one that fits to you:

Code:
Section "Module"
        Load  "glxserver_nvidia"
        Load  "glx"
EndSection

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Samsung"
        ModelName    "Syncmaster T24B530"
EndSection

Section "Device"
        Identifier  "Card0"
        Driver      "nvidia"
        BusID       "PCI:1:0:0"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        SubSection "Display"
                Viewport   0 0
                Depth     1
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     4
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     8
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     15
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     16
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection
 

mickey

Aspiring Daemon

Reaction score: 293
Messages: 731

startx used to give blank screen with frozen cursor but now gives an error the XKEYBOARD keymap compiler (xkbcomp) reports: > Internal error: could not resolve keysym XF86FullScreen - Error from xbcomp are fatal to the X server.
I am using quarterly, packages only and xorg 7.7.3.
I was asking about the version of your x11-servers/xorg-server in particular, i.e.
pkg query "%v" xorg-server

When startx fails, chances are sddm wont work either. You haven't provided any information about what's in your xorg configuration. Did you at some point use Xorg -configure to generate a configuration file? To work out this issue, I would recommend you delete your current xorg configuration files or move those out of the way and start afresh with a single file that contains a single Device section to specify the graphics driver to use:
Code:
Section "Device"
    Identifier "GeForce"
    Driver "nvidia"
EndSection
With that in place, try whether startx works to start up Xorg.
 
Top