KDE5 akonadi is not running ,wrong ownership on runtime directory

rjohn

Member

Reaction score: 6
Messages: 81

Hello

just upgraded my freebsd 11.2 to 12.1 and kde4 to kde5,pkg upgraded etc.

when i try to start kmail or other apps that need akonadi i get the message that is not running

i tryed :
Code:
freebsd# akonadictl start
D-Bus session bus is not available!
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = akonadictl path = /usr/local/bin pid = 41799
KCrash: Arguments: /usr/local/bin/akonadictl start
KCrash: Attempting to start /usr/local/lib/libexec/drkonqi
QStandardPaths: wrong ownership on runtime directory /var/run/user/1004, 1004 instead of 0
QStandardPaths: wrong ownership on runtime directory /var/run/user/1004, 1004 instead of 0
dbus is running

freebsd# service dbus start
dbus already running? (pid=1019).

i also tryed to stop it and start it same error

i guess the problem is something with : "wrong ownership on runtime directory /var/run/user/1004, 1004 instead of 0"

any idea how to fix it?
 

mjollnir

Daemon

Reaction score: 699
Messages: 1,154

  • /var/run/user/<your-uid> should be owned and accessible only by you.
  • Which display manager do you have? x11/sddm?
Standard disclaimer:
  • install the docs: pkg install {de,en}-freebsd-doc, replace de with your native tongue, and point your favorite browser to /usr/local/share/doc/freebsd.
  • You can add to the ALIAS section of /usr/local/etc/pkg.conf message: "query '[%C/%n] %M'",, read through all pkg message|less and apply the requested settings.
  • Instead of less(1), you may find sysutils/most more user-friendly. Beginners will prefer edit(1) or editors/nano instead of vi(1).
 
OP
rjohn

rjohn

Member

Reaction score: 6
Messages: 81

thanks for your reply it seems that i have the ownership of that folder :

Code:
freebsd# cd /var/run/user/
freebsd# ls
1004
freebsd# ls -l
total 4
drwx------  7 user  user  512 Sep 15 09:55 1004
yes i have installed the SDDM
 

mjollnir

Daemon

Reaction score: 699
Messages: 1,154

I guess it's related to the upgrade from KDE4 to KDE5 and/or the display manager (sddm(1)).
  • From /usr/ports/UPDATING: With Plasma 5.17 the startup script has been renamed. People who use the .xinitrc method to start Plasma have to call the new binary.
    Previously: exec ck-launch-session startkde
    Change to: exec ck-launch-session startplasma-x11
  • Did you go through all pkg message & do as requested?
  • My 1st try would be to start KDE manually, without sddm(1): service sddm disable & stop, then echo "exec ck-launch-session startplasma-x11" >>~/.xinitrc & startx
 

T-Daemon

Daemon

Reaction score: 470
Messages: 1,011

You could try on a newly created user if starting the applications show the same error. I'm thinking of plasma5.x using different configuration files, directories, options.
 
OP
rjohn

rjohn

Member

Reaction score: 6
Messages: 81

i have read the messages from pkg and its about

sysctl net.local.stream.recvspace=65536
sysctl net.local.stream.sendspace=65536
i have run the following commands since i installed kde5 BUT i saw that i have to run this command every time i boot,how i can make this permanent ?

pkg did not upgrade from kde4 to kde5 ,it removed complete kde4 and i installed later the kde5.

following those steps :
My 1st try would be to start KDE manually, without sddm(1): service sddm disable & stop, then echo "exec ck-launch-session startplasma-x11" >>~/.xinitrc & startx

i got a KWIN crash msg

if i remember correct i did not touched the xinitrc for the kde4

Code:
freebsd# cat xinitrc 
#!/bin/sh

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/usr/local/etc/X11/xinit/.Xresources
sysmodmap=/usr/local/etc/X11/xinit/.Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then







    xrdb -merge $sysresources

fi

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap
fi

if [ -f "$userresources" ]; then







    xrdb -merge "$userresources"

fi

if [ -f "$usermodmap" ]; then
    xmodmap "$usermodmap"
fi

# start some nice programs

if [ -d /usr/local/etc/X11/xinit/xinitrc.d ] ; then
    for f in /usr/local/etc/X11/xinit/xinitrc.d/?*.sh ; do
        [ -x "$f" ] && . "$f"
    done
    unset f
fi

twm &
xclock -geometry 50x50-1+1 &
xterm -geometry 80x50+494+51 &
xterm -geometry 80x20+494-0 &
exec xterm -geometry 80x66+0+0 -name login
i will try later with new account and let you know,thank you both for your help!
 

mjollnir

Daemon

Reaction score: 699
Messages: 1,154

i have read the messages from pkg and its about

sysctl net.local.stream.recvspace=65536
sysctl net.local.stream.sendspace=65536
i have run the following commands since i installed kde5 BUT i saw that i have to run this command every time i boot,how i can make this permanent ?
  • Put that in sysctl.conf(5), e.g. echo net.local.stream.recvspace=65536 >>/etc/sysctl.conf.
  • Some other sysctl knobs can only be set @boot, these go into loader.conf(5) (or /boot/loader.conf.local if you like) and then the value must be inside double quotes.
  • If you use echo(1) to place settings into loader.conf(5) or rc.conf(5), don't forget to quote the quotes with a backslash like this: echo net.local.stream.sendspace=\"65536\" >>/boot/loader.conf.
  • To edit rc.conf(5), sysrc(8) is recommended, e.g. sysrc kld_list+=" moduleX". You can also use sysrc(8) with the -f /boot/loader.conf switch.
  • In general, the guideline is to only place into loader.conf(5) what is needed to boot or can only be set @boot, and put all other sysctl knobs into sysctl.conf(5) and other settings in rc.conf(5) (or rc.conf.local), e.g. kld_list="module1 module2 ..." or kld_list="${kld_list} module9" # comment what module9 is needed for.
  • EDIT I have set noclobber in a global /etc/csh.cshrc to prevent myself from accidentally overwriting files with echo x y z >file when I forget an ">".
My 1st try would be to start KDE manually, without sddm(1): service sddm disable & stop, then echo "exec ck-launch-session startplasma-x11" >>~/.xinitrc & startx

i got a KWIN crash msg [...]
Code:
freebsd# cat xinitrc
#!/bin/sh
[...]
twm &
[...]
The KDE start scripts do all that resource setup themself. Backup that file mv ~/.xinitrc ~/.xinitrc.install and have only
Code:
#!/bin/sh
exec ck-launch-session startplasma-x11
I don't know if the shebang line (1st line) is necessary, neither if chmod a+x ~/.xinitrc is needed.
 
OP
rjohn

rjohn

Member

Reaction score: 6
Messages: 81

mjollnir editing /etc/sysctl.conf solved the :

sysctl net.local.stream.recvspace=65536
sysctl net.local.stream.sendspace=65536 problem,thanks.

after moding xinitrc it boots but same error

akonadi console error
*edit*
with new created user as T-Daemon suggested and it works! both users are wheel and operator members.

Code:
drwx------  7 user   user   512 Sep 17 09:53 1004
drwx------  7 user1  user1  512 Sep 17 09:48 1005
(user1 is the new)
 

mjollnir

Daemon

Reaction score: 699
Messages: 1,154

  • Try running akonadiselftest from a terminal window. You can click on an item to see the log file. Follow the link to the KDE userbase wiki.
  • Consider to ask for help in a KDE forum.
  • The brute-force method would be to erase all Akonadi configs. Unfortunately, they are splattered in various directories: cd; find . -name 'akonadi*'. You may rm -fr these from a console, when KDE is not running. Hopefully Akonadi will recreate them as needed. But since you upgraded, this would erase all your setup like mail accounts etc., so it would be good to know which specific file or directory is the offending one & keep all others.
 
Top