KDE severe flickering GUI with intel graphics

Running 12.1 with quarterly packages (just updated)

T470s with intel graphics. Running drm-kmod and xf86-video-intel, and rc.conf has kld_list="/boot/modules/i915kms.ko"

Also xorg.conf has
Code:
Section "Device"
        Identifier  "Card0"
        Driver "intel"
        Option "AccelMethod" "sna"
        Option "TearFree" "true"
EndSection
The flicker happens any time I mouse over a KDE GUI element, like the panel or the popup menus. It does not happen with running apps. Only KDE elements.

Any ideas where to start troubleshooting this?
 
If you use drm-kmod you don't need xf86-video-intel neither those lines in xorg.conf.
I suggest you to get rid of them.
Thanks for spotting this, I eliminated KDE from this system so I can't test without re-installing. However I can confirm that removing those lines from xorg.conf and removing xf86-video-intel was ok. The system works without them.

I'm not sure I'm ready to get involved with installing KDE again. I was also hitting a very irritating gpg wallet issue, see Thread 78396 and possibly Thread 73386.
 
T470s with intel graphics. Running drm-kmod and xf86-video-intel, and rc.conf has kld_list="/boot/modules/i915kms.ko". Also xorg.conf has
Code:
[...]
        Option "AccelMethod" "sna" [...]
The flicker happens any time I mouse over a KDE GUI element, like the panel or the popup menus. It does not happen with running apps. Only KDE elements.

Any ideas where to start troubleshooting this?
1. It is not recommended to have a custom xorg.conf(5); if one fiddles around with, at least please RTFM. Better let Xorg(1) do it's automagic configuration.
2. From intel(4) (bold and italics to highlight what relates to your issue):
  • Option "AccelMethod" "string"
    [...] "UXA" (Unified Acceleration Architecture) is the mature backend that was introduced to support the GEM driver model. It is in the process of being superseded by "SNA" (Sandybridge's New Acceleration). Until that process is complete,...
Translation for consumers: the SNA accelerator is not stable yet.
 
If your screen flickers, one thing I can suggest is to compile drm/kmod and xf86-video-intel (and frankly the rest of KDE) from ports, rather than packages. Packages are pre-made on a different machine than yours, so while your machine is unlikely to complain, running pre-compiled stuff is a bit like trying to eat a pack of store-bought frozen waffles instead of waffles freshly made from scratch at home.
 
Same issue for me happened on both Linux and FreeBSD with Intel Graphics and the latest KDE, I no longer run KDE because this flickering is very annoying, never found a fix for it. I do remember when I tried Debian Linux with a slightly dated version of KDE and other things, this flickering didn't occur, so maybe it has something to do with the latest KDE, I don't know.
 
Same here. Tried the suggestions in this topic, no change. Switched to XFCE instead. It's not 100% fixed, but completely usable. The only time it's really noticable problems are in Google Maps/Streetview when zooming/scrolling around and roughly the bottom 1/3rd of the screen lags on updates. Under KDE, there were all sorts of update lags, even typing in xterm! No issues at all with KDE on my nvidia gpu powered desktop.

I was actually beginning to wonder if I there was GPU or RAM issues on the laptop, but it seems it's the Intel driver or something between the driver and the desktop. I even did a forced pkg upgrade of everything just in case something was out of sync.
 
Top