Kde not working.

SAJM

Active Member

Reaction score: 13
Messages: 138

Here is what I have
Dell E4300 Laptop
Freebsd 11.1 RELEASE #0 321309

I followed the kde install from the freebsd manual.

Here is what I got:

WARNING:
New keymap: In /etc/rc.conf replace keymap=uk.iso.kbd by keymap=uk


I did that and the warning ended but lost the £. If I change it back I get the £ back and the same warning message. At this stage I opted for the £

I also get the following messages:
X server /usr/local/bin/X cannot be executed

and

X server for display :0 cannot be started, session disabled.

If I try and run startx I get: Command not found
 
Last edited:
D

Deleted member 9563

Guest


The correct command would be startkde unless you've set otherwise. Also remember that you need the following in your /etc/rc.conf.
Code:
hald_enable="YES"
dbus_enable="YES"
kdm4_enable="YES"

If you're using kdm then it should start automatically.
 
OP
S

SAJM

Active Member

Reaction score: 13
Messages: 138

All 3 entries you listed were already in rc. config.

When I ran startkde I got:
$DISPLAY is not set or cannot connect to the X server.

I'm guessing the display configuration at present is just set up for a simple text screen and the full VGA driver specific to this laptop is not installed.
 
OP
S

SAJM

Active Member

Reaction score: 13
Messages: 138

Ive been reading up on this and it seems to me that

"The intel driver is part of the default options for x11/xorg. Actually, the default options of x11-drivers/xorg-drivers. Either way, it is installed by default"

If this is the case I do not have a display problem but am still no closer to starting KDE.
 
D

Deleted member 9563

Guest


Uninstalling KDE first might be worthwhile. I don't think is should make any difference, but I've encountered where it does. First X then KDE if there are any issues.
 
OP
S

SAJM

Active Member

Reaction score: 13
Messages: 138

Woo Hoo. It's working however I still have the keyboard error I eluded to in my original post.
 
Top