KDE not starting

Paul Floyd

New Member


Messages: 8

#1
Hi

After my last pkg upgrade, kdm wasn't starting. I noticed that I was a bit behind the times with my release version (11.0-RELEASE-p1, which dropped support in December 2017). So I upgrated to 11.0-RELEASE-p15.

Now kdm is starting but I get

"Could not start kdeinit4. Check your installation."

/var/log/kdm.log ends with

(==) Using system config directory "/usr/local/share/X11/xorg.conf.d"
klauncher(1103) kdemain: No DBUS session-bus found. Check if you have started the DBUS server.
kdeinit4: Communication error with launcher. Exiting!
kdmgreet(1098)/kdecore (K*TimeZone*): KSystemTimeZones: ktimezoned initialize() D-Bus call failed: "Not connected to D-Bus server"

kdmgreet(1098)/kdecore (K*TimeZone*): No time zone information obtained from ktimezoned

** (ck-get-x11-display-device:1116): WARNING **: DISPLAY is not set

dbus does seem to be running:

messagebus 712 0.0 0.0 21600 2748 - Is 19:45 0:00.02 /usr/local/bin/dbus-daemon --system
paulf 1153 0.0 0.0 33148 3276 - I 19:55 0:00.00 dbus-launch --sh-syntax --exit-with-session --autolaunch 853f62d09d125b0433a06120581780c8
paulf 1154 0.0 0.0 21600 2644 - Is 19:55 0:00.00 /usr/local/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session

Edit:
I just looked in ~/.xsession-errors

startkde: Starting up...
/usr/local/lib/libkdecore.so.5: Undefined symbol "fdatasync"
startkde: Could not start kdeinit4. Check your installation.

Looks like this could be the issue.


Any suggestions?
 
Top