Solved KDE does not start after pkg update

inf3rno

Active Member

Reaction score: 15
Messages: 164

I have 12.1-STABLE on a computer. I did a pkg install node today to install a webserver. After that the system wrote that there is a new pkg version and there are other applications I can update too. After installing the updates I was no longer able to start applications from KDE and after rebooting the system KDE did not start. If I do ck-launch-session startplasma-x11, then I got $DISPLAY is not set, or cannot connect to the x server. If I do startx, then I got something like Cannot mix incompatible Qt library (5.15.0) with this library (5.15.2). Is this normal that an update breaks the desktop?
 
Last edited by a moderator:
OP
I

inf3rno

Active Member

Reaction score: 15
Messages: 164

I checked meanwhile qt5-core was upgraded to 5.15.2. I don't think this is normal, such a little version change should not break anything. I wrote to the maintainer.
 
OP
I

inf3rno

Active Member

Reaction score: 15
Messages: 164

Is there a simple way to downgrade that single package instead of reinstalling the whole KDE? In the pkg documentation I don't find anything useful. I guess removing it would remove all the packages that depend on it, which will make a complete mess. I have it in the pkg cache, so in theory I could reinstall it from there.
 
OP
I

inf3rno

Active Member

Reaction score: 15
Messages: 164

I got in email that I did only a partial update, that's why I get this error. I think that I updated Qt5 core with Firefox and all the other Qt libraries were not updated, that's why KDE did not work. It is weird, I mean such a small version change should not break compatibility in most of the projects or if so, then I would pack everything into a single library instead of multiple small ones.

I did a
Code:
pkg update
pkg upgrade
it wrote some issue with the nvidia driver, but I did not care. After a reboot KDE works again, so I think this is solved.
 
OP
I

inf3rno

Active Member

Reaction score: 15
Messages: 164

Firefox doesn't depend on anything from QT5 or KDE.
Thanks! Then it was a different application with Qt5 core dependency. I am not sure where I could check it, as far as I can tell pkg install logs are non-existent.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 10,665
Messages: 36,409

Nothing is there, I guess it was cleared by reboot.
It doesn't get cleared with a reboot. It may have been rotated though. Then look in /var/log/messages.0.gz or /var/log/messages.1.gz, etc.

See newsyslog.conf(5) and /etc/newsyslog.conf.
 
OP
I

inf3rno

Active Member

Reaction score: 15
Messages: 164

It doesn't get cleared with a reboot. It may have been rotated though. Then look in /var/log/messages.0.gz or /var/log/messages.1.gz, etc.

See newsyslog.conf(5) and /etc/newsyslog.conf.
Does not matter, I formatted the drive and installed something else meanwhile for testing.
 
Top