KDE cross-cursor bug after loggin

tennea9

Member

Reaction score: 5
Messages: 25

Hello everyone,
I'm new there.
I solicit your help.

I'm trying to make run KDE5 on my computer and I'm having difficulties.
I followed the topic with Fissy, having same problem, but it still doesn't work.

KDE is starting. But when it comes to log in, I enter the password, press enter and nothing more happens.

I tried everything from tutorials. Already installed FreeBSD 10 times. Not working. Always the same problem.

I have an Intel Core i7 vPro.
Fujitsu Celsius H series.
I virtualized FreeBSD, everything worked perfectly.
Now I try it on real hardware, it doesn't work.

Anyway, here is everything I tried from the beginning (just after FreeBSD installation) :

Always logged as Root.
# pkg install kde5 kde-baseapps sddm xorg xf86-video-intel sudo nano

Then I edited fstab, adding /proc...
Then visudo and I change root (all)=all to my username.
Then dbus, sddm, hald enabled.

I added the exec.. on xinitrc

Did I forget something ?

What's wrong !?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,708
Messages: 39,306

I followed the topic with Fissy
Something lost in translation?

Already installed FreeBSD 10 times. Not working. Always the same problem.
It's pointless to reinstall the entire OS for this issue, the problem is not with the OS.

Then dbus, sddm, hald enabled.
Did you start them too? Or simply rebooted? I would recommend not enabling sddm until you verified X is actually working correctly. So, set it to "NO" for the time being. Try with startx. Make sure that works first, when that works correctly you can enable sddm again.
 

Alexander88207

Aspiring Daemon

Reaction score: 528
Messages: 754

KDE or sddm uses the wayland session as default but doesnt seem to work, you can change the session on the login screen.
 
OP
T

tennea9

Member

Reaction score: 5
Messages: 25

X starting properly. No problem with this.

Alexander88207. Thank you so much.
It was wayland. User session doesn't work neither, plasma session works !!

At last !!

Thank you very much !
 
Top