jwm segfaults via firefox

I got certainly segfaults during closing or launching Firefox in jwm session. I have rebuild firefox and jwm many times, with different gcc options but same.

Code:
Segmentation fault: 11 at address 0x805326900

Fatal server error:
Caught signal 11 (Segmentation fault: 11). Server aborting
---
FreeBSD 9.0-CURRENT 11/3 snapshot, amd64
 
Same problem in other OS. I built latest svn snapshot on jwm site and no such problems so far. Extra benefit is that round corners :)

I informed port's owner for this situation via mail.
 
Code:
X.Org X Server 1.7.5
Release Date: 2010-02-16
X Protocol Version 11, Revision 0
Build Operating System: FreeBSD 8.0-RELEASE-p6 i386
Current Operating System: FreeBSD IBM 8.2-RC1 FreeBSD 8.2-RC1 #0: Thu Dec 23 15:32:35 UTC 2010     [email]root@almeida.cse.buff[/email]
alo.edu:/usr/obj/usr/src/sys/GENERIC i386
Build Date: 23 December 2010  03:10:20PM

Current version of pixman: 0.18.4
        Before reporting problems, check [url]http://wiki.x.org[/url]
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.

(==) Log file: "/var/log/Xorg.0.log", Time: Tue Jan 18 00:42:55 2011
(II) Loader magic: 0x81def20
(II) Module ABI versions:
        X.Org ANSI C Emulation: 0.4
        X.Org Video Driver: 6.0
        X.Org XInput driver : 7.0
        X.Org Server Extension : 2.0
(--) Using syscons driver with X support (version 2.0)
(--) using VT number 9

(--) PCI:*(0:1:0:0) 1002:4c57:1014:0530 ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500] rev 0, Mem @ 0
xe0000000/134217728, 0xc0100000/65536, I/O @ 0x00003000/256, BIOS @ 0x????????/65536
List of video drivers:
        ati
        radeon
        intel
        mach64
        nv
        openchrome
        r128
        radeonhd
        apm
        voodoo
        vmware
        vmwlegacy
        tseng
        trident
        tga
        tdfx
        sis
        siliconmotion
        savage
        s3virge
        s3
        rendition
        nouveau
        newport
        neomagic
        mga
        i740
        i128
        glint
        ark
        dummy
        cirrus
        chips
        fbdev
        vesa
(II) LoadModule: "ati"
(II) Loading /usr/local/lib/xorg/modules/drivers/ati_drv.so
(II) Module ati: vendor="X.Org Foundation"
        compiled for 1.7.5, module version = 6.13.0
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 6.0
(II) LoadModule: "radeon"
(II) Loading /usr/local/lib/xorg/modules/drivers/radeon_drv.so
(II) Module radeon: vendor="X.Org Foundation"
        compiled for 1.7.5, module version = 6.13.0
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 6.0
(II) LoadModule: "intel"
(II) Loading /usr/local/lib/xorg/modules/drivers/intel_drv.so
(II) Module intel: vendor="X.Org Foundation"
        compiled for 1.7.5, module version = 2.7.1
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 6.0
(II) LoadModule: "mach64"
(II) Loading /usr/local/lib/xorg/modules/drivers/mach64_drv.so
(II) Module mach64: vendor="X.Org Foundation"
        compiled for 1.7.5, module version = 6.8.2
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 6.0
(II) LoadModule: "nv"
(II) Loading /usr/local/lib/xorg/modules/drivers/nv_drv.so
(II) Module nv: vendor="X.Org Foundation"
        compiled for 1.7.5, module version = 2.1.17
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 6.0
(II) LoadModule: "openchrome"
(II) Loading /usr/local/lib/xorg/modules/drivers/openchrome_drv.so
(II) Module openchrome: vendor="http://openchrome.org/"
        compiled for 1.7.5, module version = 0.2.904
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 6.0
(II) LoadModule: "r128"
(II) Loading /usr/local/lib/xorg/modules/drivers/r128_drv.so
(II) Module r128: vendor="X.Org Foundation"
        compiled for 1.7.5, module version = 6.8.1
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 6.0
(II) LoadModule: "radeonhd"
(II) Loading /usr/local/lib/xorg/modules/drivers/radeonhd_drv.so
(II) Module radeonhd: vendor="AMD GPG"
        compiled for 1.7.5, module version = 1.3.0
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 6.0
(II) LoadModule: "apm"
(II) Loading /usr/local/lib/xorg/modules/drivers/apm_drv.so
(II) Module apm: vendor="X.Org Foundation"
        compiled for 1.7.5, module version = 1.2.2
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 6.0
(II) LoadModule: "voodoo"
(II) Loading /usr/local/lib/xorg/modules/drivers/voodoo_drv.so
(II) Module voodoo: vendor="X.Org Foundation"
        compiled for 1.7.5, module version = 1.1.0
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 6.0
(II) LoadModule: "vmware"
(II) Loading /usr/local/lib/xorg/modules/drivers/vmware_drv.so
(II) Module vmware: vendor="X.Org Foundation"
        compiled for 1.7.5, module version = 11.0.1
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 6.0
(--) vmware: X configured to use vmwgfx X driver assume who ever did that knows what they are doing
(--) vmware: Please ignore above "[drm] failed to load kernel  module "vmwgfx""
(II) vmware: Using vmwlegacy driver everything is fine.
Segmentation fault: 11 at address 0x0
        
Fatal server error:
Caught signal 11 (Segmentation fault: 11). Server aborting

        
Please consult the The X.Org Foundation support
         at [url]http://wiki.x.org[/url]
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.


hmmmmmm?
Caught signal 11 (Segmentation fault: 11). Server aborting

"Who is to blame?" and "What to do?" - eternal questions in Russian culture and history.
 
Top