just installed freebsd 32bit version. cannot mount any device.

senenmut

New Member


Messages: 13

Hi,
I have just installed FreeBSD 32 bit and installed Xorg together with XFCE desktop is running.
The case is that I cannot mount any device.
No CD ROM, no USB and no harddrive.
May I ask what package to install that I can mount any?

Kindly Regards
Senenmut
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 8,302
Messages: 32,149

The mount(8) command is part of the OS.

What are the exact commands you're using? And what errors are you getting?
 

Phishfry

Son of Beastie

Reaction score: 1,594
Messages: 4,582

If you enable these settings Xfce will use gvfs to automount attached devices.
/etc/rc.conf
Code:
dbus_enable="YES"
hal_enable="YES"
 
OP
OP
senenmut

senenmut

New Member


Messages: 13

hi,
i simple add a usb stick on usb and type
Code:
ls /dev/da*
/dev/da0  /dev/da0s1
as root
then i type
Code:
mount_msdosfs /dev/da0s1  /media/usbstick
then i can see the file on USB stick
it is a small .txt file.
But i cannot open it or open it from xfce icon.
Xfce Icon says "not mounted"
But i can copy it with cp TEST.txt /home/user/
I have successfully mounted the FAT32 Usbstick from terminal.
How to mount it in XFTE Desktop with the right mouse button on "Mount Volume" ?

i realized that the mounting function has many options depending on the file system.
so let us say "SUCCESS" with the usbstick here.
Wonder what to change for direct mounting on desktop.
The USBSTICK ICON is seen on the desktop.
If i klick on that it is not working. Only from terminal.

WBR
SM
 

Phishfry

Son of Beastie

Reaction score: 1,594
Messages: 4,582

Have you tried to mount the USB stick this way:
mount -t msdosfs /dev/da0s1 /media/usbstick
 
OP
OP
senenmut

senenmut

New Member


Messages: 13

If you enable these settings Xfce will use gvfs to automount attached devices.
/etc/rc.conf
Code:
dbus_enable="YES"
hal_enable="YES"
Hi ,
i have the lines you say. except not
Code:
hal._enable
i have here
Code:
hald_enable[/CODE
i hold hald_enable.

oh , the icon does not appear anymore on desktop as before.
ONLY terminal mounting works here at the time.
 
OP
OP
senenmut

senenmut

New Member


Messages: 13

Have you tried to mount the USB stick this way:
mount -t msdosfs /dev/da0s1 /media/usbstick
Yeah that works too. it is mounted. i unmound with
Code:
umount -f /media/usbstick
The desktop icon of medium doesn't appear anymore.
 
OP
OP
senenmut

senenmut

New Member


Messages: 13

The mount(8) command is part of the OS.

What are the exact commands you're using? And what errors are you getting?
thank you SirDice. i have pasted the lines in the next answer. please take a look.
i realized that the xfce desktop environment has the TUNAR filemanager installed and...
that the plugin called "thunar-volman" is a extension that must be installed manually by code (not pkg)
allows to "automount" usb devices.
However , as a beginner in UNIX BSD , i will mount devices by code.
Thats why i have installed UNIX OS - (not GNU)
The real follower of System V.
he he
 
Top