Jail can't connect to single machine

I have a jail that can connect to everything, except one single machine that I need to connect to.

I have enable ping in jail.. I can ping (google DNS), I can telnet (for testing) to port 22 on several of my machines.

There is just this one machine I can't connect to. Can't ping, can't connect to the port I need (Postgresql). There is no firewall on the target machine and I tested from multiple different machines to verify I can ping and telnet to the postgresql port from everywhere else to the target machine.

This jail is meant to be a postgresql slave from another postgresql server and that is the machine I can't connect to.

Any suggestions? A little puzzled how it seems to only be failing to connect to the one machine, but seems to be working with everything else.
Can the host of the jail connect to that particular machine?

No, it can't.

Have tried a number of other machines from the host too and all seems to be working, so it is just this one m machine Starting to wonder if it is an issue with the provider where I am hosting the machine.

Tried traceroute from the host to the machine in question and just get
1 * * *
2 * * *

Any ideas/suggestions on how to troubleshoot? At this point will move the work to another machine, but still would like to find what is going on so if it happens in the future I would know what to do.
If the host of the jail can't connect then the jail will fail also. At this point with the info that I have it is difficult to guess what the problem might be. I would start by troubleshooting connectivity issues on the target. The machine that runs postgresql.