Issues with non-BSD OS's using IOHYVE

I am having issues with BHYVE/IOHYVE and I was hoping someone could offer some guidance, or new something I could check. Being fairly new to FreeBSD (let alone BHYVE!) I am quite at a loss.

I've tried several different options and I have been to several different places:

iohyve isolist

iohyve create freebsd103 10G
iohyve install freebsd10.3 FreeBSD-10.3-RELEASE-amd64-bootonly.iso
iohyve console freebsd103

This works like a charm! And setup seems to work just like you think it would.

But then I wanted to try an ubuntu installation. I have also tried setting the os=ubuntu and os=default

iohyve create ubuntuserver 15G
iohyve set ubuntuserver loader=grub-bhyve
iohyve set ubuntuserver os=debian
iohyve set ubuntuserver ram=1024M
iohyve set ubuntuserver cpu=2
iohyve set ubuntuserver con=nmdm1
iohyve install ubuntuserver ubuntu-14.04.4-server-amd64.iso

But after the last line I see:
Installing ubuntuguest...
And this will sit there until I close my SSH client (I have waited for hours). And dropping into the console has nothing listed either.

Is there anything obvious that I am doing wrong? I have tried poking and prodding at this but I think it may just be beyond me.

Thanks for the support!
yes. Thank you for your response!

grub2-bhyve-0.40                   =   up-to-date with remote

Unsurprisingly I discovered that if I drop into a console for the VM and start the VM I received a "kernel not found" error. But this seems to just mean that the installation never did anything.


After more playing around I found out that it is actually working! ... SORT OF!

Typically when I dropped into the console I would eithe see nothing, or "OK" which would simply repeat whenever the enter key was pressed the entire way down the screen.

Upon some further investigating, at one point I actually saw the loading/installation screens! but they were "disfigured" and whenever I tried to change the installation selection the cursor would disappear, or part of the window would disappear...




The only issue is that these screen that I did get, I had no idea what I was selecting because there was no cursor or it was impossible to tell where it was. Perhaps this is something as simple as some display setting I need to change in putty?

*EDIT 2*
By opening Putty and going into "Translations" and changing it to Win1252 (Western) it seems to be showing like it should now!
SmartOS is absolutely fantastic, I have to agree. I have 5 servers in production running various iterations of SmartOS. That said, bhyve is super cool. It's nice to use, and iohyve has a reasonable setup now. I'm using FreeBSD 11 on my desktop, bhyve is here just to run the debian containers where i need things like Jasper Studio, the latest iteration of eclipse, etc. I have a SmartOS server in the crawlspace running whatever else I need, and primarily it's there for storage and Windows VMs. Overall the two setups very much complement each other. I'm glad to not have to use VirtualBox on FreeBSD anymore! using bhyve with iohyve is a serious relief and a fantastic setup! thanks to all the folks who put the time in to accomplish this wonderful product.
I'm getting exactly the same behavior as #3 but in GNOME Terminal and also the FreeNAS shell. I'm running FreeNAS 9.10 and iohyve v0.7.7. Any clues on how to get this working?