Issue with Plasma5 | Xorg or Wayland | Thinkpad T450

Hello folks,

I’m back on the forum and in the freebsd community, it’s been a while. I sold my Xiaomi for a thinkpad (I stop telling my life).

Sorry if the answer is somewhere, I’m seeking through the forum since yesterday, same for stackoverflow, didn’t find the answer…

I set up FreeBSD 13 STABLE on my thinkpad, I loaded the modules I needed to get WiFi, I loaded the i915 module also to be able to get X server working (which works fine), and I installed KDE Plasma following this article https://euroquis.nl/kde/2021/04/30/wayland.html

I’ve got an exec in my .xinitrc, I’d love to make it work under Xorg before even trying Wayland, which is my final goal.

I also set the /proc in the fstab just as explained in the blog article, and I started using the /usr/local/bin/startplasma-wayland.sh, black screen

And I’m getting an issue. SDDM loads fine, when I click on the “virtual keyboard” at the bottom left, it splits the screen in half, and the bottom is grey (no keyboard shown).
I can type my password with no issue at all, but when I press enter, I see the mouth cursor, and the screen remains black.


By the way, when I type “startx” on my tty, it does shows up TWM (which works, but I prefer a bit more modern WM), which leads me to : I’ve incorrectly set up my .xinitrc :
```
exec startkde
````

I can startx only with root, with my main user it doesn't work, I've an X error.
My user was added to "video" group tho.

Also when I launch firefox on TWM on Xorg I have this :

root@deckardbsd:~ # firefox&
[1] 25817
root@deckardbsd:~ # Crash Annotation GraphicsCriticalError : |[0][GFX1~]: glxtest: VA-API test failed: failed to initialise VAAPI connection. (t1=1.6472) [GFX1]: glxtest: VA-API test failed: failed to intialise VAAPI connection.
It does look like a graphical error. I must take a look on that, but if someone has an idea..
Firefox launchs well tho.

I must see if that works better with this driver : libva-intel-media-driver-22.4.3 (which doesn't work with wayland I think, it's a "legacy driver for xorg")
Do anyone have an idea ? Do you want me to share any kind of configuration file ?
Thanks for reading me,

Deckard.
 

Attachments

  • F1662D02-3AEB-4887-9DBF-A0B138F4A2D8.png
    F1662D02-3AEB-4887-9DBF-A0B138F4A2D8.png
    391.7 KB · Views: 174
  • 312D5A4C-4969-4785-AD83-B689F29925CC.png
    312D5A4C-4969-4785-AD83-B689F29925CC.png
    485.2 KB · Views: 161
  • 5648EE20-7523-4C6A-AED7-A7E3188C15E8.png
    5648EE20-7523-4C6A-AED7-A7E3188C15E8.png
    611.4 KB · Views: 150
  • 02CE258E-0250-4B36-AC34-DC7424E970C6.png
    02CE258E-0250-4B36-AC34-DC7424E970C6.png
    660 KB · Views: 151
Well, this is going better, I have a perfectly working environment now, on X11, not wayland yet.
However, I'm still not able to start X with my main user, it just works with "root" which kinda sucks.
 
Welcome back.

exec startkde
Does this still work? startkde was deprecated some time ago and replaced by startplasma-x11 and startplasma-wayland.

VA-API test failed: failed to intialise VAAPI connection.
You don't need VA-API (hardware video acceleration) for regular Xorg operation, so that's not the problem here.

Can you startx as user if you disable SDDM?
 
Hello, thanks for your answer ! I'm glad going back to BSD, there are good things on GNU/Linux, but too much things I don't like either.
No it doesn't work. SDDM is currently disabled, however startx won't work as a regular user, I'm gonna try to take a photo of a capture.
 
I the regular user in the 'video' group (or in the 'wheel' group)? He should be in one of those 2 for xorg video driver to work.
 
Well I have this error (sorry for the potato picture)

And yes he is in wheel and video group :
root@deckardbsd:/usr/home/deckard # id deckard
uid=1001(deckard) gid=1001(deckard) groups=1001(deckard),0(wheel),44(video)
 

Attachments

  • Screenshot_20220903-201017.jpg
    Screenshot_20220903-201017.jpg
    1.1 MB · Views: 151
Did you install graphics/drm-510-kmod ?
Try with plain twm , and do some glxinfo to see if you get 3D graphics acceleration .
Also the Xorg logs could be helpful, as well as which generation of intel gpu do you have ?
 
Hello Monwarez,

root@deckardbsd:/usr/home/deckard # inxi -G
Graphics:
Device-1: Intel HD Graphics 5500 driver: vgapci
Device-2: J8AFCI1TK Integrated Camera type: USB driver: N/A
Display: server: X.Org 1.21.1.4 driver: loaded: modesetting
unloaded: vesa resolution: 1600x900~60Hz
OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2)
v: 4.6 Mesa 21.3.8
root@deckardbsd:/usr/home/deckard #

I did installed this driver :

pkg install drm-fbsd13-kmod

root@deckardbsd:/usr/home/deckard # pkg info drm-fbsd13-kmod
drm-fbsd13-kmod-5.4.191.g20220604_1
Name : drm-fbsd13-kmod
Version : 5.4.191.g20220604_1
Installed on : Thu Sep 1 23:11:17 2022 CEST
Origin : graphics/drm-fbsd13-kmod
Architecture : FreeBSD:13:amd64
Prefix : /usr/local
Categories : kld graphics
Licenses : MIT and GPLv2 and BSD2CLAUSE
Maintainer : x11@FreeBSD.org
WWW : https://github.com/freebsd/drm-kmod/
Comment : DRM modules for the linuxkpi-based KMS components
Options :
DEBUG : off
SOURCE : off
Annotations :
FreeBSD_version: 1300139
repo_type : binary
repository : FreeBSD
Flat size : 10.8MiB
Description :
amdgpu, i915, and radeon DRM modules for the linuxkpi-based KMS components.
Currently corresponding to Linux 5.4.144 DRM.
This version is for FreeBSD 13.

WWW: https://github.com/freebsd/drm-kmod/
 
How old is your stable ? From UPDATING
20210202:
Various LinuxKPI functionality was added which conflicts with DRM.
Please update your drm-kmod port to after the __FreeBSD_verison 1300139
update.
20220501:
AFFECTS: users of drm-current-kmod and drm-devel-kmod
AUTHOR: manu@FreeBSD.org

Both ports where removed.
If you were using either one of them directly (i.e. without using
graphics/drm-kmod metaport) use graphics/drm-510-kmod.
If you have some problems with this one try drm-54-kmod and report
a bug on https://github.com/freebsd/drm-kmod.
You seems to have hardware acceleration, don't really know why not with a regular user though
 
I'm trying to compile graphics/drm-510-kmod to check if that changes things !
EDIT : it didn't

Still not able to startx as user, only as root which is terrible for security
 
You have /usr/local/libexec/Xorg.wrap with the setuid bit set ?
If this file does not exist or does not have the setuid bit then it explain why you have to startx as root.
 
You have /usr/local/libexec/Xorg.wrap with the setuid bit set ?
If this file does not exist or does not have the setuid bit then it explain why you have to startx as root.
Yep it does :/

root@deckardbsd:/usr/home/deckard # ll /usr/local/libexec/Xorg.wrap
-r-sr-xr-x 1 root wheel 8920 Aug 30 10:43 /usr/local/libexec/Xorg.wrap*
root@deckardbsd:/usr/home/deckard #
 
I remember solving a similar problem with the virtual keyboard in SDDM on Linux. I think a python module was missing. Check the SDDM log.
 
I remember solving a similar problem with the virtual keyboard in SDDM on Linux. I think a python module was missing. Check the SDDM log.
Thanks, I've checked the logs, and found nothing. I'm gonna try later, with a SSH connection and a tail -F on the log file to check exactly what it says
 
Back
Top