Solved Issue with Intel Wireless Card

Gato Preto

New Member


Messages: 12

Hi folks!

I've a MSI GP62 2QE computer, it has an Intel(R) Dual Band Wireless-AC 3160 which wasn't detected while installing FreeBSD 11.0 RELEASE.

I installed and when I get rid of an awful time with GRUB I realised it did not have internet connection. FreeBSD doesn't detect the device. I have customized /boot/loader.conf with some lines of iwnsomething[fw/g2afw/g2bfw]_load="YES" which I found in a FreeBSD firmware page (I don't remember which).

I also asked for help in the #freebsd Freenode chat, I got some answers but none worked. Somebody knows how to fix this? If needed I can provide more information.

Thanks in advance!

PS. Because of all this wlan couldn't be configurated nor other things.
 
OP
G

Gato Preto

New Member


Messages: 12

Update: FreeBSD says that modules have been recognized, however, I cannot configure a wlan interface even though FreeBSD recognizes the Intel Wireless Card. Cheers!
 

bookwormep

Well-Known Member

Reaction score: 229
Messages: 360

The FreeBSD Handbook chapter 30.3 Wireless Networking should have some basic principles you can use.

Do you have a wireless account with an ISP provider? The SSID and password/key data should be useful for you when you set
up the /etc/wpa_supplicant.conf.

You need to set up /etc/rc.conf with :
Code:
wlans_iwm0="wlan0"
Code:
ifconfig_wlan0="WPA DHCP"
or something similar if you use another wifi-application.

Hope this helps.
 
OP
G

Gato Preto

New Member


Messages: 12

The FreeBSD Handbook chapter 30.3 Wireless Networking should have some basic principles you can use.

Do you have a wireless account with an ISP provider? The SSID and password/key data should be useful for you when you set
up the /etc/wpa_supplicant.conf.

You need to set up /etc/rc.conf with :
Code:
wlans_iwm0="wlan0"
Code:
ifconfig_wlan0="WPA DHCP"
or something similar if you use another wifi-application.

Hope this helps.

Hi! Thanks for you answer, unnafortunately it doesn't work. FreeBSD keeps saying that there isn't a wlan interface configured even though it recognizes the Wireless Card. I've followed the process detalled at FreeBSD iwn firmware article. For example when I type the commands shown in that page, the OS says: "ifconfig:SIOCIFCREATE2: Device not configured". Cheers!
 

ljboiler

Well-Known Member

Reaction score: 163
Messages: 441

Do you have the proper modules listed in /boot/loader.conf ?
Code:
if_iwm_load="YES"
iwm3160fw_load="YES"
 
OP
G

Gato Preto

New Member


Messages: 12

I have done what yo
Do you have the proper modules listed in /boot/loader.conf ?
Code:
if_iwm_load="YES"
iwm3160fw_load="YES"

Thanks for your suggestion, I modified /boot/loader.conf with those two paragraphs. I tried to create the wlan interface as described in the Handbook and in the Firmware page without success. Notwithstanding this fact, after restarting the inet services and rebooting the machine, suddenly FreeBSD created automatically a wlan interface and internet connection started working normally. Thanks for the answer!
 
Top