Solved Issue when copying music to sdcard which contains japanese fonts

Alexander88207

Aspiring Daemon

Reaction score: 697
Messages: 896

Hello,

I like to listen to japanese music and that includes that many songs are in japanese from the title.

This is normally not a problem but when i do want to copy it over to sdcard it says invalid filename (From thunar) and when i try it using the system console it says Invalid argument.

I have looked around before but never found a solution.

If the reason is that the Japanese characters are missing in the basic system, how can I add them so that everything is displayed correctly in the system console?

Many thanks in advance!
 

diizzy

Aspiring Daemon

Reaction score: 236
Messages: 638

I have to admit that I'm only using PuTTY (in UTF-8 mode) and it works as expected, what is your locate set to? Could it be that the msdos/fat/fat32 filesystem module doesn't like unicode?
 
OP
Alexander88207

Alexander88207

Aspiring Daemon

Reaction score: 697
Messages: 896

The sdcard was formated by phone and is FAT32.

I do have to say that it works when i transfer the files via Filezilla to phone directly to the card. But that not that i want to do every time. Since i do use this card in an external player.
 
OP
Alexander88207

Alexander88207

Aspiring Daemon

Reaction score: 697
Messages: 896

What is your locate set to?

Code:
$ locale
LANG=C.UTF-8
LC_CTYPE="C.UTF-8"
LC_COLLATE="C.UTF-8"
LC_TIME="C.UTF-8"
LC_NUMERIC="C.UTF-8"
LC_MONETARY="C.UTF-8"
LC_MESSAGES="C.UTF-8"
LC_ALL=
 

diizzy

Aspiring Daemon

Reaction score: 236
Messages: 638

Uhm... That looks a bit weird?

LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_COLLATE=C
LC_TIME="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_ALL=
 
OP
Alexander88207

Alexander88207

Aspiring Daemon

Reaction score: 697
Messages: 896

Uhm... That looks a bit weird?

LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_COLLATE=C
LC_TIME="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_ALL=

These are the default settings. I never had problems with them, so I left them like that.
 
Top