Solved Issue getting realtek wireless network card (rtwn driver) working on new FreeBSD installation

non-entity

New Member


Messages: 2

FreeBSD newbie here. I just installed FreeBSD 12.0-RELEASE AMD64 on a small box and am having issues getting the PCI realtek wireless network card to work.

Running ifconifg -a displays the motherboards ethernet controller and the loopback device, but not my wireless card. However, running pciconf -lv,I can see the PCI card detected (excuse me for the terrible screenshot).

6766



So my assumption at this point is that the driver either isn't installed or not enabled. I'm pretty sure the driver is the rtwn driver because I've previously had issue getting this card to work on a NetBSD installation and that driver was selected (although I suspect it didn't work), so looking at the man page, I go ahead and add

Code:
if_rtwn_pci_load="YES"

to /boot/loader.conf and rebooted but the issue seems to persist. Am I right to assume a (missing) driver issue? If so, how can I install the driver onto my existing installation? I didn't see any reference to the rtwn driver in the supported hardware page, but obviously it exists.

So upon a little more research, I found this which notes I have to load some additional firmware modules along with accepting a license in loader.conf, which I have, but the driver still doesn't attach to the device and pciconf still sees it as none0. Any idea why, despite all the correct modules being loaded, the driver refuses to attach to the device. I'm pretty confident my card is supported by the driver, but I could be mistaken.
 

Attachments

  • 20190728_160340-min.jpg
    20190728_160340-min.jpg
    463.7 KB · Views: 317
Last edited:

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,327
Messages: 38,844

Realtek has a habit of changing the hardware design without changing the hardware identification. So you may have some variant that's not recognized.
 
OP
N

non-entity

New Member


Messages: 2

Thanks for the info. I managed to patch the driver source and build a custom kernel and it appears the rtwn driver now attaches to my card and have internet. Not sure if this is something of use to anyone else but the card works fine for me now!
 
Top