iSCSI Problems with mlx4en (ConnectX-3) under FreeBSD 13.0

Adam Stasiak

New Member


Messages: 2

I have a system exposing zvols over iSCSI for virtual machines.
They are connected to over either:
  • 2-port intel 10GbE card using the ixgbe driver
  • 2-port ConnectX-3 infiniband card using the mlx4en driver
Under system 12.2, everything worked fine.
After upgrading to 13.0, I started seeing disk errors upon launching the VMs, to the point they wouldn't even boot.

I don't see any issues if I connect to them over the Intel cards, only the Infiniband.
I also don't see any issues with iperf, or transferring files over the link using nc.

I do have a second almost identical system that I haven't yet upgraded to 13.0, so I can compare differences between the two. So far I ran ibstat, and the results are almost identical. Apart from GUIDs and SM/Base IDs, the only meaningful difference is one bit in the capability mask.

Anyone have any suggestions on either how to resolve, or other troubleshooting steps I could take to suss out the problem?
 
Top