UFS Is there a generic driver to use Raid cards as regular SATA cards?

Is there a way to use a RocketRaid or any Raid card as a regular SATA interface on FreeBSD? I'm hoping that there's a generic driver that treats about any PCI card with a SATA interface as a regular SATA interface, regardless of whether it uses any RAID or other features.

It's a RocketRaid 1520, which is an old one. In the past, I didn't have luck using this card and its raid features on FreeBSD, even though it listed it on the box, but was still a version behind what was later supported on FreeBSD from this manufacturer. If I could use it as a regular SATA device, without RAID or any special features. I haven't seen the card's BIOS, but maybe I missed if it had one.

This PC is able to boot up from a USB, which is very helpful. I'm trying on FreeBSD, NetBSD and maybe any other OS to access a UFS filesystem, which was running on FreeBSD. It's a 32bit motherboard, so I'm limited on which OS's I can try, and it only has IDE connections. FreeBSD does have an OS image on it, even if 32bit is no longer 1st tier.

Also, interested in using JBOD (Just a Bunch of Disks) mode on the PCI card, if it will work.

While Linux has more drivers for hardware, I haven't known of a rescue or live cd in it which can access UFS.

Edit: I found the online manual to this piece of hardware, and there's supposed to be a second BIOS screen for this card. I may have remembered this, but forgot about it. There isn't this on my computer, so either the BIOS settings need to be adjusted, the card is incompatible with this board, or this card is broken. There's supposed to be a screen that indicates to press Ctrl-H to enter configuration.
Can’t help with the main question but on that “second BIOS screen … Ctrl+H” sounds like what I’ve seen on some RAID controllers as the machine boots.

So you won’t find it in the main BIOS screens maybe? Start the machine and watch closely as it boots up - you might get a message during that about RAID set-up and pressing Ctrl+H
I think the card is bad. I tried it on another legacy PC and it didn't work either. I held the keys down, and tried tapping it too.

At least I won't have to worry about the status of that specific card anymore, even though it may be useful for others as a legacy adapter to make use of old hardware, even without RAID or other special features. Maybe this would be something useful for BSD's intended for use with legacy or 32bit hardware (NetBSD for instance), which FreeBSD is moving away from legacy hardware.

That leads to me finding an adapter or PCI card that works with a generic SATA driver that's natively supposed by FreeBSD, without needing to be compiled into the kernel.

A USB to SATA cable/adapter may be a good option, depending if it needs a driver for that, and whether the information from it is to be merely retrieved or if the disk will be booted from. Hopefully a disk on a USB adapter is treated like a regular USB thumb drive.
PCI SATA controllers are dog slow, don't bother...
I had a Promise SATA 300 TX4 at one time and it barely did 50mbyte/s off all 4 channels at the same time.
It would still be good for data retrieval, but that's good to know for considering it as a permanent or heavy use harddisk.
RAID cards and so called "RAID" controllers on motherboards simply add the trailing sectors that geom_mirror adds. I accidentally discovered this years ago when enabling hardware RAID on an ASUS MB. It immediately recognized the geom_mirror as a mirror of its own making.

The reason some of these so-called "hardware" RAID controllers are so slow is because they're not hardware RAID controllers. They simply add the necessary sector to allow an O/S driver see the disks as mirrors for an O/S driver to implement the mirror in the driver.