ZFS Is ashift=14 on a holiday?

Mage

Member

Reaction score: 16
Messages: 98

I wanted to test whether using 16k sector size SSD-s would be better for my use case than 4k. Unfortunately, I couldn’t compare them. It seems that ashift is maxed out at 13 regardless of whether I used vfs.zfs.min_auto_ashift or gnop.

FreeBSD 11.2 didn’t accept vfs.zfs.min_auto_ashift=14. zpool create refused the 16k .nop device ("invalid argument" or something).

I ended up comparing a 4k + ashift=12 disk ( zpool create recognized it) with a 16k + ashift=9 disk ( zpool create got it wrong) and with a 16k + ashift=13 disk (using vfs.zfs.min_auto_ashift=13).

As I had little time I ran only a few rounds of non-scientific tests. Unpacking a kernel tar.gz file took the same time on every disk. (I tried it maybe 20 times on each).

pgbench, on the other hand, showed me a significant difference. The ashift=9 on the 16k was about 20% slower than the ashift=12 on the 4k (no surprise). Compared to the 4k, the ashift=13 on the 16k disk was about 10-12% faster though. While it wasn’t accurate testing, I have run the tests on each disk for about 5-7 times. I wonder whether using the proper sector size would improve it further.

Is there a reason we can’t have ashift=14 now?
 
Top