ipw 2100 can see wifi networks but won't connect

Ben V

New Member


Messages: 1

I've been banging my head into the wall trying to figure this out.

I have an older laptop with an Intel Pro Wireless 2100 card that works perfectly well under Linux.

I had a bit of trouble getting the card to be detected by ifconfig as wlan0, but I finally got it working. Now scanning with ifconfig shows nearby networks, so I know the driver is working.

Every time I go to connect to a network with WPA_supplicant, it spits out "wrong key" and continuously cycles through the connection>handshake>wrong key proccess.

Problem is, I know beyond a shadow of a doubt that the psk I'm giving it is correct, and I know it's not the router, since it does the same thing with another router, and even my phone's hotspot.

I've tried using wpa_gui, wifimgr, and even the ghostBSD networkmgr (which is also able to see the networks, but always gives the same errors as WPA_Supplicant if I run it from terminal to see the log)

I'm at a complete loss and cannot figure this out for the life of me. Would greatly appreciate a solution.
 
Top