I am seeking help here as despite reading the documentation for rc.conf I am clearly missing something. I wish vtnet0 to be disabled on boot along with ipv6 being disabled on vtnet1. I am perhaps being lead astray from the output so forgive me, I am a new user to BSD.

rc.conf:

Code:
hostname="ldnnfs01.intra.xxxx.uk"
keymap="uk.kbd"

ipv6_network_interfaces="none"

# public network
ifconfig_vtnet0="IFDISABLED"
#ifconfig_vtnet0="inet xx.xx.xx.230 netmask 255.255.254.0""
#defaultrouter="xx.xx.xx.1"

# private management lan
ifconfig_vtnet1="inet 10.8.96.7 netmask 255.255.240.0 mtu 1450"
defaultrouter="10.8.96.3"
sshd_enable="YES"
ntpd_enable="YES"

# Set dumpdev to "AUTO" to enable crash dumps, "NO" to disable
dumpdev="NO"

One would assume that the status: active should be inactive, disabled or non-existent under vtnet0 and there should be no IPV6 or nd6 options listed?

Code:
        vtnet0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=6c07bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,LRO,VLAN_HWTSO,LINKSTATE,RXCSUM_IPV6,TXCSUM_IPV6>
        ether 56:00:03:03:aa:a3
        media: Ethernet 10Gbase-T <full-duplex>
        status: active
        nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
vtnet1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1450
        options=6800bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,LINKSTATE,RXCSUM_IPV6,TXCSUM_IPV6>
        ether 5a:00:03:03:aa:a3
        inet 10.8.96.7 netmask 0xfffff000 broadcast 10.8.111.255
        media: Ethernet 10Gbase-T <full-duplex>
        status: active
        nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>


Taking the interface down using ifconfig still yields the same output as above.

Any guidance would be greatly appreciated, James.
 

SirDice

Administrator
Staff member
Administrator
Moderator
I wish vtnet0 to be disabled on boot along with ipv6 being disabled on vtnet1.
Don't define the interface, all non-configured network interfaces are down by default. If you want to force it you can define it like this:
Code:
ifconfig_vtnet0="down"

One would assume that the status: active should be inactive
The status indicates the physical connection itself. Active means there's a "live" ethernet cable attached.
 

olli@

Developer
Note that "IFDISABLED" only disables IPv6 on an interface, see ifconfig(8). The interface is still brought up.
To forcibly disable an interface completely, use "down". Or omit the ifconfig line for that interface completely. Since you don’t configure an IP address for that interface anyway, it doesn’t really matter much.
(Note that it will still be marked “active” if it has a physical network connection. This is the equivalent of the link LED on the physical port, i.e. RJ45 socket.)

As for the IPv6 options: That’s normal. Those option keywords only indicate which features are supported. It does not mean that the interface is actually configured for IPv6 (it is not because it does not have an IPv6 address, not even a link-local address).
 
Gentleman thank you very much for your time and explanations it is of great value. I have amended my rc.conf file to include
Code:
ifconfig_vtnet0="down"
I keep the other options for vtnet0 so I can bring up the WAN side should I wish. I was looking at the interface status from a Cisco/Juniper perspective when you shutdown an interface it going down/down.
 
Top