IPMI on supermicro: no keyboard => use console, howto

jcatrysse

New Member

Thanks: 1
Messages: 15

#1
I had serious problems with the IPMI module (AOC-SIM1U+) on Supermicro systemboards, the keyboard hangs directly when in FreeBSD. The solution is using the serial console. This is how to connect on COM3 (0x3E8).

Pay attention, COM2 has another address (0x2F8)!

If you misconfigured the system by accident and it all hangs... don't worry, you can change the COM address in the BIOS ;)

Serial console, boot loader:
/etc/make.conf
Edit /etc/make.conf and set BOOT_COMCONSOLE_SPEED to the new console speed (e.g. BOOT_COMCONSOLE_SPEED=115200). Then, recompile and install the boot blocks and the boot loader:
cd /sys/boot && make clean && make && make install

/boot/device.hints
Add the appropriate hint.sio.* or hint.uart.* entries to /boot/device.hints.
Code:
hint.uart.2.at="isa"
hint.uart.2.port="0x3E8"
hint.uart.2.irq="5"
hint.uart.2.baud="115200"
/boot.config
Create /boot.config in the root directory of the a partition on the boot drive and set the correct flag. (-Dh for serial and internal consoles)
echo "-Dh" > /boot.config

/boot/loader.conf
Set the correct values in loader.conf. Please pay attention to use the correct speed and COM port address.
Code:
boot_multicons="YES"
boot_serial="YES"
console="comconsole,vidconsole"
comconsole_speed="115200"
comconsole_port="0x3E8"
Serial console, once into the system:
/etc/ttys
Configure TTY and test the correct COM port. Modify the line, ttyu0 = com1, ttyu1 = com2, , ttyu2 = com3. Modify the baudrate to reflect your COM port speed.
Code:
ttyu2   "/usr/libexec/getty std.115200"   vt100   on secure
After making any changes to /etc/ttys, send a SIGHUP (hangup) signal to the init process to force it to re-read its configuration file:
kill -HUP 1

Troubleshooting: https://www.freebsd.org/doc/handbook/term.html

Hope this is helping someone out.

Regards :beer:,
Jan
 
Top