• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

IPMI on supermicro: no keyboard, no CD, no USB => disable USB 2.0 howto

jcatrysse

New Member

Thanks: 1
Messages: 15

#1
I had serious problems with the IPMI module (AOC-SIM1U+) on Supermicro systemboards, the keyboard hangs directly when in FreeBSD. Furthermore installation of a new system using the virtually mounted CD or USB does not work with the KVM.

This seems to be due to buggy USB support and can be fixed by disabling USB 2.0 support.

In an eralier post I fixed this by moving to a serial console (SOL): https://forums.freebsd.org/threads/58324/
That however is very handy but does not fix the CD/USB problem...

This can be fixed manually at each start-up by escaping to the loader prompt and typing these commands:
Code:
set hint.ehci.0.disabled=1
set kern.cam.boot_delay=10000
boot
In some other internet posts these command also seem to have been useful:
Code:
set hw.usb.ehci.no_hs=1
set debug.acpi.disabled=hostres
I dis-encourage to make these changes permanent because it disables USB 2.0, but it can be done by this command:
Code:
echo 'hint.ehci.0.disabled="1" ' >> /boot/loader.conf
echo 'kern.cam.boot_delay="10000" ' >> /boot/loader.conf
Hope this can help someone out, it surely helped me out.

Regards,
Jan