Solved iocage fetch fails to build tree

Just set up a FreeBSD 10.2 box with root on mirrored ZFS from scratch to learn how to use iocage.
After the system install I issued
pkg install iocage
which first installed pkgng and then iocage.

Then I issued
iocage fetch
which first downloaded the base system and then updated it. After installing the updates "Creating basejail ZFS datasets... please wait." was displayed.
Some moments later I got the message "Failed to build new tree."
(Please apologize I cannot post the long message log here, as it is a very basic system without any additional software installed.)

Cleaning up the failed install using
iocage clean -a
and then reinstall (as suggested here) didn't solve the issue.
Any idea what I could have done wrong?
Big oopsie... it was a dying CMOS battery. Time and date was back to 2013.
I found out when I got a strange error when attempting a ports install. "make install" complained that the new versions' files are older than the current ones.
After fixing the system datetime "iocage fetch" worked smoothly.
Please apologize my stupidity...