Solved Interface comes up with IFDISABLED - I don't know why

spky

New Member

Reaction score: 1
Messages: 3

Hello,
I have a simple box running FreeBSD 12. It is running some Jails, and I want it to have a dynamic network configuration.

As network configuration I have this in my /etc/rc.conf:
Code:
hostname="box"

ifconfig_bge0="SYNCDHCP"

ipv6_default_interface="bge0"
ifconfig_beg0_ipv6="inet6 accept_rtadv"
ipv6_defaultrouter="fe80::%bge0"
ipv6_privacy="YES"

rtsold_enable="YES"
gateway_enable="YES"
ipv6_gateway_enable="YES"
cloned_interface="lo0"
netwait_enable="YES"
Now, if I boot this box, the interface bge0 comes up with nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>.

If I run manually ifconfig bge0 inet6 -ifdisabled accept_rtadv up, wait a little for rtsold and do a service routing restart everything works.

I tried to change the line in /etc/rc.conf to ifconfig_beg0_ipv6="inet6 -ifdisabled accept_rtadv", but no success..

Why does the Interface refuses to speak IPv6 on boot?
What did I do wrong, how can I fix that? It was definitely working before.

Thanks for your help!
 

Phishfry

Son of Beastie

Reaction score: 1,398
Messages: 4,122

I suggest you look in /etc/defaults/rc.conf
It is our prototype file and contains all possible settings.
Right off the bat I noticed this setting you might want to try:
rtadvd_enable="YES"

Also be advised that netwait has options:
### Network link/usability verification options
netwait_enable="NO" # Enable rc.d/netwait (or NO)
#netwait_ip="" # Wait for ping response from any IP in this list.
netwait_timeout="60" # Total number of seconds to perform pings.
#netwait_if="" # Wait for active link on each intf in this list.
netwait_if_timeout="30" # Total number of seconds to monitor link state.

You can further manipulate it by modifying the /etc/rc.d/netwait script.
 
OP
OP
spky

spky

New Member

Reaction score: 1
Messages: 3

I suggest you look in /etc/defaults/rc.conf
That's a nice hint, tanks.

So I added netwait_if="bge0" and the
No interface or IP address listed, nothing to wait for
message on boot does not show up anymore. Great!

Why should I enable rtadvd? I do not want to send router advertisements from this box. For the fun of it, I enabled it and rebooted, no success, the problem stays the same.

I am not even sure if this has something to do with the config in /etc/rc.conf. To verify I booted the installer from the USB-Stick, and the interface also comes up with IFDISABLED.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,678
Messages: 30,592

All interfaces are disabled if they're not used or configured. For example, for lagg(4) you need to "up" the individual interfaces or else they remain disabled:
Code:
ifconfig_igb0="up"
ifconfig_igb1="up"
ifconfig_lagg0="laggproto lacp laggport bge0 laggport bge1"
Same when using a bridge:
Code:
ifconfig_igb0="up"
ifconfig_igb1="up"
ifconfig_bridge0="addm igb0 addm igb1 up"
 
OP
OP
spky

spky

New Member

Reaction score: 1
Messages: 3

I guess I just found out why the interface was not used or configured...

ifconfig_beg0_ipv6="inet6 accept_rtadv"
I had a typo in there: beg0 instead of bge0. Just fixed this and now everything works fine.
Wow, that is embarrassing. Anyway, thanks for all your help!
 
Top