Intel video and screentearing

Terpentijn

Active Member

Reaction score: 11
Messages: 103

I have an older intel video on board. On Linux I installed a card.conf in [path]/user/local/etc/X11/xorg.config.d[/path] to take care of the tearing and it worked ok. On my first FreeBSD install I did the same but I still got a lot of tearing even after installing the intel xorg driver (can’t remember the exact name). Can somebody advice me on the best way to prevent this tearing? Intel driver or the one that comes with fbsd.? Or do I also need to install compton. I will use openbox, i3 and/or Xfce. I prefer openbox...
 

shepper

Aspiring Daemon

Reaction score: 320
Messages: 873

intel(4)
Option "TearFree" "boolean"
Disable or enable TearFree updates. This option forces X to
perform all rendering to a backbuffer prior to updating the
actual display. It requires an extra memory allocation the same
size as a framebuffer, the occasional extra copy, and requires
Damage tracking. Thus enabling TearFree requires more memory and
is slower (reduced throughput) and introduces a small amount of
output latency, but it should not impact input latency. However,
the update to the screen is then performed synchronously with
the vertical refresh of the display so that the entire update is
completed before the display starts its refresh. That is only
one frame is ever visible, preventing an unsightly tear between
two visible and differing frames. Note that this replicates what
the compositing manager should be doing, however TearFree will
redirect the compositor updates (and those of fullscreen games)
directly on to the scanout thus incurring no additional overhead
in the composited case. Also note that not all compositing
managers prevent tearing, and if the outputs are rotated, there
will still be tearing without TearFree enabled.

Default: TearFree is disabled.
 

wammes

New Member


Messages: 1

Yes, i know of this option. On my Linux boxes I always used it. No flickering. However, with the intel driver loaded in FreeBSD I still got flickering. That’s why I was wondering if a combo between the driver and I.e.compton would solve it. Or maybe the default fbsd driver works better.
 

recluce

Active Member

Reaction score: 39
Messages: 164

For an under-powered NUC running as a HTPC, installing Compton was the only way to have a tearing-free XFCE session. The issue does not happen when the same box runs kodi as a session, so I guess there is something about XFCE here.
 
OP
Terpentijn

Terpentijn

Active Member

Reaction score: 11
Messages: 103

For an under-powered NUC running as a HTPC, installing Compton was the only way to have a tearing-free XFCE session. The issue does not happen when the same box runs kodi as a session, so I guess there is something about XFCE here.
I put 20-intel.conf in /usr/local/etc/X11/xorg.config.d
Code:
Section "Device"
    Identifier     "Card0"
    Driver    "intel"
    Option    "DRI" "3"
    Option    "AccelMethod" "SNA"
    Option    "TearFree" "true"
EndSection

This alone was not enough though. I also have thee following lines in /boot/loader.conf
Code:
#DRM
drm.i915.enable_rc6=7
drm.i915.semaphores="1"
drm.i915.enable_fbc="1"

And in /etc/rc.conf I load
Code:
kld_list="i915kms"


Xfce runs fast and buttersmooth. NO screen tearing. I'm a happy user.
 

Michael_S

New Member


Messages: 10

I put 20-intel.conf in /usr/local/etc/X11/xorg.config.d
Code:
Section "Device"
    Identifier     "Card0"
    Driver    "intel"
    Option    "DRI" "3"
    Option    "AccelMethod" "SNA"
    Option    "TearFree" "true"
EndSection

This alone was not enough though. I also have thee following lines in /boot/loader.conf
Code:
#DRM
drm.i915.enable_rc6=7
drm.i915.semaphores="1"
drm.i915.enable_fbc="1"

And in /etc/rc.conf I load
Code:
kld_list="i915kms"


Xfce runs fast and buttersmooth. NO screen tearing. I'm a happy user.
Hi mate,
Would you be able to let me know whether this method will work for Lenovo ideapad 100S-14IBR please?

My setup: FreeBSD 12.2+XFCE4+sddm login manager

Thanks & Best Regards
Michael
 
OP
Terpentijn

Terpentijn

Active Member

Reaction score: 11
Messages: 103

Hi mate,
Would you be able to let me know whether this method will work for Lenovo ideapad 100S-14IBR please?

My setup: FreeBSD 12.2+XFCE4+sddm login manager

Thanks & Best Regards
Michael
I can’t. I don’t own a Lenovo ideapad 100S-14IBR. Why don’t you try it out? It’s not much work. I must say that on FreeBSD 13 I dropped the lines in loader.conf. They’re no longer needed. The new drm-fbsd13-kmod has become very very good.
 

usakhncit

Active Member

Reaction score: 19
Messages: 202

I was facing the same issue on my Linux box. Now its working fine, after using following:
Code:
(user:lap:~) cat /etc/X11/xorg.conf.d/20-intel.conf
Section "Device"
    Identifier     "Intel Graphics"
    Driver         "intel"
    Option        "AccelMethod" "uxa"
EndSection
 
OP
Terpentijn

Terpentijn

Active Member

Reaction score: 11
Messages: 103

I was facing the same issue on my Linux box. Now its working fine, after using following:
Code:
(user:lap:~) cat /etc/X11/xorg.conf.d/20-intel.conf
Section "Device"
    Identifier     "Intel Graphics"
    Driver         "intel"
    Option        "AccelMethod" "uxa"
EndSection
Hm, try to add the tearfree option. It will be even better. And for me "AccelMethod" "SNA" works better than UXA. I guess it depends on the hardware.
 

usakhncit

Active Member

Reaction score: 19
Messages: 202

Hm, try to add the tearfree option. It will be even better. And for me "AccelMethod" "SNA" works better than UXA. I guess it depends on the hardware.
"TearFree" did not work in my case. In my case, I got the best results with "UXA" option.
 

Michael_S

New Member


Messages: 10

I can’t. I don’t own a Lenovo ideapad 100S-14IBR. Why don’t you try it out? It’s not much work. I must say that on FreeBSD 13 I dropped the lines in loader.conf. They’re no longer needed. The new drm-fbsd13-kmod has become very very good.
Hi,
I am using the mentioned laptop but screen is tearing and slow. Is FreeBSD13 a stable version? I am using 12.2 but very slow. Can't do much.
Thanks & Best Regards
Michael
 
Top