Intel HD Graphics 5500 driver issue

  • Thread starter Deleted member 64474
  • Start date
D

Deleted member 64474

Guest


Hello! I'm new to FreeBSD and so far I'm lovin' it. But I have an issue with the installation of the driver for my laptop graphics. I read that I need the drm-next-kmod for my graphics, but on freshports it says that it's deleted - https://www.freshports.org/graphics/drm-next-kmod/.
I don't know if there is a way to make my graphics work, but Xorg was giving server error until I installed drm-kmod with pkg and load it in the /boot/loader.conf. With this loaded, Firefox scrolling is weakly said.. ugly. I searched the forum but it only shows discussions about the deleted port drm-next-kmod so they really aren't helpful for me. Thank you for any further help. I am not sure if Mobile Computing is where I should be asking this question.
 

T-Daemon

Daemon

Reaction score: 880
Messages: 1,755

I installed drm-kmod with pkg and load it in the /boot/loader.conf.

You didn't mention which FreeBSD version you are running. If you are on 12.2-RELEASE don't use package graphics/drm-kmod, use port. The package is known not always to work with 12.2.

Also you apparently missed the post-install message.

Enable the driver by adding in /etc/rc.conf: kld_list="/boot/modules/i915kms.ko", make sure the user is in the video group, reboot.

If the problems persist execute cat /var/log/Xorg.0.log | nc termbin.com 9999 . That will return a URL, please post it in your message.
 
Top