Installs but isn't a terminal

Keith Z

New Member


Messages: 4

I've installed FreeBSD-10.2-RELEASE-amd64-dvd1.iso about 15 times now. The checksum on the iso is good. The first time was encouraging until it quit letting me in. On the third day (that would be six or seven restarts after halt -p shut downs. It quit being a terminal. Upon startup the screen shows
login:

but typing on the keyboard no longer produces anything on the display.

I type root [ENTER]

After many tries which display my password on the screen from time to time (so I didn't mis-type it).

I get in and the screen shows numerous general announcements and at the bottom
Code:
Edit /etc/motd to change this login announcement .
root@UltraBSD:~ #
hitting [lsENTER] once shows
root@UltraBSD:~ #
root@UltraBSD:~ #
Hitting [ENTER] again shows
root@UltraBSD:~ # ls
Hitting [ENTER] again shows
.cshrc                   .k5login                    .login                    .profile             
Hitting [ENTER] again shows
root@UltraBSD:~ #
This is what I started with on my initial install and what I want except that typing produces nothing on the screen until multiple [ENTER]'s.

Is there a place that I am missing in the documentation?

In reading installation hints, FAQ's, several youtubes which go as my very first install I just can't understand where I am or how to fix it.

Also on the first install there was a countdown timer at the first menu and on each boot. That timer now does not appear. Menu selections seem to make no difference.

I finally did an eleven hour disk shred thinking that some flag was set on the disk and the installer reacted to it but this made no difference.

Perhaps there is some BIOS setting?

I'm running an AMD four core on a MSI motherboard but I just can't believe that it is a hardware problem.
 

wblock@

Beastie Himself
Developer

Reaction score: 3,683
Messages: 13,851

First, try a different keyboard to rule that out.

Then consider what has been changed from the defaults. Root shell?
 
OP
K

Keith Z

New Member


Messages: 4

I was using a Logitech wireless keyboard and mouse. I switched to a PS2 wired keyboard. Just plugging in the keyboard it worked just the same.

I did a reinstall with the wired keyboard and the behavior is the same.

The system halts at
Code:
Starting background system checks in 60 seconds.
Fri Nov 6 22:14:28 EST 2015
I give it Enter. It responds

Code:
FreeBSD/amd64 (UltraBSD) (ttyv0)
login:
I type root nothing appears on the screen.
I hit Enter and it responds:

Code:
FreeBSD/amd64 (UltraBSD) (ttyv0)
I type password nothing appears on the screen which is normal (although it seems like there was a blinking white box after my first install).

I type Enter. It responds
Code:
FreeBSD directory layout:  man hier
where it halts until I type Enter. It responds
Code:
Edit /etc/motd to change this login announcement.
I type Enter.
Code:
root@UltraBSD:~ #
And I'm in a working system except nothing that I type appears on the screen until I hit multiple Enter.

Any suggestions? Do I have the formatting right in this reply?
 

wblock@

Beastie Himself
Developer

Reaction score: 3,683
Messages: 13,851

Again: what settings have been changed from the default? It sounds like a wrong terminal type was chosen.
 
OP
K

Keith Z

New Member


Messages: 4

I did a reinstall with all defaults. Wrong timezone whatever it wanted. It is a normal system with the white box data entry point for the install process until new user addition. Which is the default. If you don't pay close attention you can easily get hopelessly stuck in new user addition since you can't tell what line you are on to say no to another new user. [sh] is the default shell. There is no difference from my previous installs in terms of the interactive shell or the lack thereof.
 
Top