Installing xorg on FreeBSD 10.3 gave this result, what now?

richardwbb

New Member


Messages: 1

Hi there,

I've came from Debian and a long time ago used FreeBSD 4.0/ 4.1 and now I feel to start using FreeBSD again. So to prepare myself, I've run inside VirtualBox, freebsd10-3-bootonly iso, and succesfully installed the base system.

Reading somewhere told me pkg install xorg was sufficient to startx. I've tried the regular freshports way, that failed horribly, so I wanted to install in such a way to get a desktop with a menu and such.

The output after startx surprises me. I've installed mouse, so the screen also can move, but I don't get why FreeBSD isn't setting the required video output and leaves the screen 640x480 text based. Please help me, http://www.freshports.org/x11/xorg-minimal didn't work. It is a testing server, with a backup so it won't hurt that I install wrong but now I just don't know where to start. I hope someone recognizes this since I have no real clue what to type in a search enige to learn from there.

freebsd-10-3-xorg.png
 

jon_d

New Member


Messages: 2

Just came here out of curiosity looking for an answer, not sure how to describe my problem either. Just stumbled across this topic and saw that picture. That's EXACTLY the problem I have with xorg. Thank for posting that picture.

But my situation is different. Had 10.3 running fine, but not updated in a while. Installed a package and it wanted to upgrade a bunch of stuff, but that ended up killing X windows. Trying to start X gives that same weird red/white "ASCII art" on the top half of the screen that you showed.

Tried to autoremove, upgrade -f and all kinds of stuff but same thing. And tried a fresh reinstall of 10.3 and that also failed. But fresh install of 11.0 worked. So I guess the latest 10.3 updates broke the drivers for my Intel 915 somehow. Not very nice. Oh well, now have to put system back together with 11.0.
 
Top