Installing openldap pkg problem

k31453

New Member


Messages: 4

I have trouble installing openldap24-server.

I am getting following error:
Code:
root@rule183:/usr/home/student # cd /usr/ports/net/openldap24-server
root@rule183:/usr/ports/net/openldap24-server # make install clean
===>  openldap-server-2.4.40_4 pkg(8) must be version 1.3.8 or greater, but you have 1.2.6. You must upgrade the ports-mgmt/pkg port first.
*** Error code 1

Stop.
So iI checked the port info :
Code:
root@rule183:/usr/ports/net/openldap24-server # pkg info pkg
pkg-1.2.6
Name           : pkg
Version        : 1.2.6
Installed on   : Thu Mar 13 08:22:24 EST 2014
Origin         : ports-mgmt/pkg
Architecture   : freebsd:10:x86:64
Prefix         : /usr/local
Categories     : ports-mgmt
Licenses       : BSD2CLAUSE
Maintainer     : portmgr@FreeBSD.org
WWW            : http://wiki.freebsd.org/pkgng
Comment        : Package manager
Shared Libs required:
        libpkg.so.1
Shared Libs provided:
        libpkg.so.1
Flat size      : 8.01MiB
Description    :
Package management tool

WWW: http://wiki.freebsd.org/pkgng
Now what is the solution to the problem?

make deinstall reinstall pkg?

If iI have 2 hosts. I did the above execution on that port now whenever I installed any software iI am getting following error:
Code:
root@rule123:/usr/ports/net # cd openldap24-server
root@rule123:/usr/ports/net/openldap24-server # make install clean
===>  openldap-server-2.4.40_4 has known vulnerabilities:
openldap-server-2.4.40_4 is vulnerable:
openldap -- denial of service vulnerability
CVE: CVE-2015-6908
WWW: http://vuxml.FreeBSD.org/freebsd/4910d161-58a4-11e5-9ad8-14dae9d210b8.html

1 problem(s) in the installed packages found.
=> Please update your ports tree and try again.
=> Note: Vulnerable ports are marked as such even if there is no update available.
=> If you wish to ignore this vulnerability rebuild with 'make DISABLE_VULNERABILITIES=yes'
*** Error code 1

Stop.
make[1]: stopped in /basejail/usr/ports/net/openldap24-server
*** Error code 1

Stop.
make: stopped in /basejail/usr/ports/net/openldap24-server
 

talsamon

Daemon

Reaction score: 277
Messages: 1,812

Recent pkg version is 1.6.1. Recent openldap-server version is 2.4.42. Update your system, please.
 
OP
OP
K

k31453

New Member


Messages: 4

Recent pkg version is 1.6.1. Recent openldap-server version is 2.4.42. Update your system, please.
My university use jail system. They have all this. We have rule host given. So iI don’t think so iI have to update all systems.

All iI need is to install it.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,670
Messages: 30,574

Your pkg(8) is way out of date. That's the error. Update that one first.
 
Top