Installing on a Mac Mini (2010 Model)

Tyler615

New Member

Reaction score: 2
Messages: 4

Hello everyone.

Over the past several days I've been trying to install/get FreeBSD 9 to work on my 2010 model Mac Mini (intel). I've gotten rid of my OS X installation and am attempting a standalone FreeBSD 9 installation. This however is not the issue. Both during installation and once I have booted into the new system, I get the following error:

Code:
bge0: watchdog timeout -- resetting
bge0: link state changed to DOWN
bge0: link state changed to UP
This occurs during network configuration of the initial install and after I have booted into the new system. As long as the interface bge0 (which is my wired ethernet interface) is UP, this error occurs. Moreover, it happens every few seconds, so when I log in to the system, it's difficult to do anything, as it stops the console from accepting input while the interface is resetting.

If I bring the interface down, I can actually do work, but without networking it's difficult to try and solve this problem, since I am assuming this is a driver/kernel issue.

I found a blog post of someone who had the same issue with different hardware, which can be found here.

However... When I tried to disable ASF features as he did, it resulted in a kernel panic. I would describe it, but it seems to be printing the same kernel panic message hundreds of times a second, so I can't read it and describe it.

I'm using the FreeBSD 9 AMD64 kernel.

Tyler
 
OP
OP
T

Tyler615

New Member

Reaction score: 2
Messages: 4

Update:

I looked into watchdog itself. I read the manual page on it, and then learned that I could disable it. So I used:

Code:
watchdog -t 0
While it stops my console from being flooded by endless complaints from watchdog, it didn't solve the connectivity problem. The watchdog error message described in my original post still occurs when I bring the interface up and try to give it an address.

Note: Wether I use DHCP or I specify an address, same issue.
 
OP
OP
T

Tyler615

New Member

Reaction score: 2
Messages: 4

Solved

I've noticed that this thread amassed a little over 100 views with no replies. Through a lot of searching, I found a solution to this issue. The solution was disabling MSI, by adding the following to /boot/loader.conf:

Code:
hw.pci.enable_msi="0"
This solved the issue of infinite watchdog resets and the network interface's inability to obtain any kind of network connectivity.

For anyone wondering how well everything else works after this issue has been solved: great. Sound is working, networking is now performing exceptionally, and X is running smoothly (using the HDMI port, not the DisplayPort). The system is now overall very stable and usable.
 
Top