Installing Freebsd 13.1 fails right after booting

Machine:

1. motherboard: asus tuf gaming z490-plus(wifi)
2. cpu: i7-10700K
3. ram: 32gb ddr4
4. no dedicated GPU

What I've tried?

I've put on my pendrive (sandisk) with installed Ventoy, these files:

- FreeBSD-13.0-RELEASE-amd64-disc1.iso
- FreeBSD-13.0-RELEASE-amd64-memstick.img
- FreeBSD-13.1-RELEASE-amd64-bootonly.iso
- FreeBSD-13.1-RELEASE-amd64-disc1.iso
- FreeBSD-13.1-RELEASE-amd64-memstick.img
- GhostBSD-22.06.18.iso
- hello-0.7.0_0G160-FreeBSD-13.0-amd64.iso

Also on my second pendrive (samsung) I've "burned" FreeBSD-13.1-RELEASE-amd64-memstick.img by using Rufus with Windows.

Each time with 13.1 version the issue is the same:

Booting starts and I see menu with FreeBSD ascii art, I can choose between multi user / single user and so on.
Both options shortly lead me to black screen with white rectangle ascii character at the top left corner of screen and mouse pointer (arrow) that I can move around - and it stays that forever.
I can press CTRL + ALT + DEL and then it restarts whole machine.

With 13.0 version it is similiar, but it hangs a little bit earlier with EFI Framebuffer data showed on screen.

Only `hello-0.7.0_0G160-FreeBSD-13.0-amd64.iso` boots completly to usable OS.

How can I install pure FreeBSD 13.1 on my machine?

Thanks for helping! <3

Booting "FreeBSD-13.1-RELEASE-amd64-memstick.img" by pendrive, video clip:
Two mirrors:
https://gfycat.com/granularelementaryharrierhawk
https://uploadify.net/9cda014ec58c7fd1/YouCut_20221204_140433286.mp4

It looks like it is common problem: https://www.reddit.com/r/freebsd/comments/tye20z/black_screen_an_mouse/
 

Attachments

  • 3a0bfb20-cff3-4461-849c-69d93075afe6photo.jpeg
    3a0bfb20-cff3-4461-849c-69d93075afe6photo.jpeg
    181.1 KB · Views: 110
Hi, same problem here.
It appears that the system boots, but you just don't see it, because the data does not go to the screen. But if the network is configured, you should be able to ssh to the system from other machine.
The problem is that the boot loader tries to boot in serial console mode while your system expect the "video" output. When you see the initial screen, press 5 once or more so that instead of:
Code:
5. Cons: Serial
you see:
Code:
5. Cons: Video
If you get bored with doing it every time while starting your already installed system, go to /boot/lua/core.lua and see how the boot_serial and boot_multicons variables are handled. This code is very clunky and these variables are not initialized there, anyway - but you might just find the function core.isSerialBoot() and hardcode it to always return false.
Yes, it's an ugly and dirty hack that... just works. I hope the boot loader will probe the motherboard properly in future versions.
 
I've tried it before with no luck. In my case it has to be something more. Maybe because wqhd resolution? Anyway with uefi everything works like in downgraded way (ugly upscaled res) but works.
 
Back
Top