Solved Installing FreeBSD 12.1 via PXE Encounters "LUA ERROR: Can not open /boot/lua/loader.lua: no such file or directory"

Elbert

New Member


Messages: 1

Hello SMEs,

I have learned from a Pluralsight course on how to PXE install Linux Distributions, e.g. CentOS7.2. And I succeeded following the guideline of the course, i.e. by setting up a DHCP, TFTP server, and FTP server, then configure the pxelinux.0 file as needed. The process is pretty neat and clear.

However, my problem is: with the posts in this forum that I could refer to, I want to PXE install a FreeBSD in my Virtualbox. But it seems to have failed in its very last step, and I can't find any more posts that could help.

Background: using a CentOS Linux 7 as the PXE server, I want to install FreeBSD-12.1-RELEASE-amd64-bootonly.iso in my Virtualbox client (Version 6.1.6 r137129 (Qt5.6.2).

DHCP worked fine with below configuration(/etc/dhcp/dhcpd.conf):

Bash:
...
...
subnet 192.168.56.0 netmask 255.255.255.0 {
  range 192.168.56.100 192.168.56.254;
  next-server 192.168.56.103;
  filename "pxelinux.0";
}

host master {
  hardware ethernet 08:00:27:BF:8A:1B;
  fixed-address 192.168.56.120;
  next-server 192.168.56.103;
  filename "pxefreebsd.0";
}
...
...
The subnet section is aimed at PXE installing Linux Distributions. Specifically, I want to install a FreeBSD for master.

NFS worked also fine with below configuration(/etc/exports):
Bash:
/var/lib/tftpboot/pxefreebsd.cfg/install 192.168.56.120(rw,no_subtree_check)
After all these configurations, when I start the master, it goes into the below error:
LUA ERROR: Can not open /boot/lua/loader.lua: no such file or directory
(this error message was displayed on the screen during master boots, nearly no different compared to the below screenshot)

And after a long while of googling solutions, nothing worked.

Among those, two useful posts came and I tried.
1. https://forums.freebsd.org/threads/lua-error-can-not-open-boot-lua-loader-lua.68635/page-2
2. https://forums.freebsd.org/threads/error-at-startup.70900/

I followed the two guides to change the FreeBSD release from 12.1 to 11.2, it gives a different error message, but almost the same as the last one:

VirtualBox_master_21_05_2020_23_40_47.png



I really need to know what is going on through this process. It seemed it has worked for an expert who wrote a post ten years ago, using FreeBSD 8 or so ( I followed his post): https://www.jzab.de/content/pxe-install-network-installation-of-freebsd-from-a-linux-box/.

Experts thank you for giving any suggestions. Best wishes.
 
Top