Solved Installing FreeBSD 10.3

I'm a newbie, who tried to install FreeBSD 10.3 into my computer.
My computer specs are as follows:
Intel Core i7-4770
WD Black 1TB
GeForce GTX 645
A Generic Motherboard (I can give you the specs if you want them)
I know a lot more parts, just ask me if you want them.

This is a prebuilt Dell Desktop, but I have changed the hard drive, from a generic Seagate Barracuda 1TB to the WD Black 1TB.
I have Windows 10 installed, and had it installed a few months before I even considered installing FreeBSD. It was not an upgrade, I purchased Windows 10 and installed it, so Windows.old does not exist on Windows partition.

I installed FreeBSD, and there were no errors all the way throughout the entire process. I even reached the last step, of the review, and I rebooted, without seeing a single error. However, when I choose from the partitions, none of them actually booted at all. I tried all of the partitions on my computer, even the Windows partition, which just booted Windows, nothing else.

Is there any problem, or any step I may have skipped when installing?

Edit 1:
When booting into the partitions, it's like they are empty, without anything installed.

I used the .img file, along with the Bootable USB maker FreeBSD recommended me to use, in their documentation.

Should I have used a the .iso file, and burnt it into a DVD?
Hello Cataleap and welcome to the community!

Could you be more specific as to what a "blinking cursor and a black screen" means? Are you greeted with a login prompt, or is the system not able to boot? If you provide more information, we'll be much more helpful in diagnosing your problem.
I'm sorry for not providing this information. Imagine what happens when you boot into an empty partition, without anything installed. This is what happens when I boot into the partition I installed it on. So I would guess that the boot manager for FreeBSD was not installed at all?
I'm pretty sure I know what's happening. When you want to multi boot, you'll have to install a multi boot capable boot loader (you could also configure the Windows boot loader to multi boot, but it's more annoying than just installing a new one). FreeBSD has its own MBR multi boot capable boot loader called boot0. It however does not support GPT partitions in the way that your setup works, so you'd have to install a different boot loader such as sysutils/grub2 or configure Windows to boot FreeBSD. If your disk is MBR (I'm doubtful of this as your PC has Windows 10 installed by Dell), then follow the steps below.

To install boot0, you'll want to boot from the installer and open up a shell. From there, you can use boot0cfg(8) to install it. I usually just run something like boot0cfg -B ada0, assuming that ada0 is actually the drive you want to install it to. Note that you want to install it to the drive that you boot from, not a slice or partition.

However, if you have a GPT disk, the above will not apply to you. You have two options, either install a new boot loader from ports(7), or configure the Windows boot loader to boot FreeBSD. If you don't want to use Windows, you'll have to use the installer to chroot(8) into the FreeBSD install and install a boot loader (you should probably install GRUB). It is simple if you know what you're doing, but if you are new to FreeBSD, it may be a bit too complicated at first. If you do feel that it is too hard, you can use EasyBCD to configure the Windows boot loader to give you the option to boot FreeBSD.
You are right, I have a GPT disk, not a MBR disk. I guess I will use EasyBCD, then, to configure Windows Boot loader to boot FreeBSD.

Edit 1:
So I got EasyBCD, but since my computer is EFI, and 'due to the limitations set by Microsoft' I can't add a boot option. I can only set Windows 10, in the Windows Boot Loader
With EasyBCD you will be able to boot from both FreeBSD and Windows 10. I haven't used EasyBCD in a while so I'm not sure as to why you can't add a boot option, but making sure you have secure boot disabled may help.
I do have secure boot disabled. I have included a picture of my boot section in my BIOS, in case there is something you know and I am not picking up.
Here is the image of my BIOS.

Here is the error message.

After clicking on help, one of the three options provided as an alternative was to use, like you mentioned, a GRUB2 EFI boot manager. I have installed multiple OS's on this computer, and have long removed the Windows 8 my Dell came with, so I don't mind getting my hands dirty. Can you please send me a good guide for installing Grub2? Thank you in advance.