Installing a Graphics Drivers

Kernan Mzelikahle

New Member

Reaction score: 3
Messages: 11

Greetings
I have noticed that on my laptops when I install FreeBSD, almost always, I run using the VESA driver. The graphics is not so good. I have read threads that talk about using the xf86-video-intel driver, and at some point mention loading i915kms.ko module. But all this does not seem to work, largely because the instructions therein are broken and leave me hanging at the very least. Long story short, I think I do not quite understand the way these drivers are being handled. Can someone point me to some literature, web-site, book, etc that I can go through and get my head around this matter. The literature I am looking for may be summarized by asking the question this way: "How can I install and configure a graphics driver on FreeBSD 11.0?"

I am running on FreeBSD 11.0. Everything else is great.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 8,057
Messages: 31,638

The Intel driver should work fine, it's only the newer GPU types (Broadwell and above) that aren't supported yet.

Kernan Mzelikahle what kind of hardware do you have?
 

scottro

Daemon

Reaction score: 526
Messages: 1,458

Are you saying that Haswell should be supported? Because it doesn't seem to be, though I haven't tried with 11.1-RC. Definitely wasn't working on 11.0 on a yoga 2.

I'll have to try when I get home and can then update. (Or maybe I just have odd hardware--it's a high resolution touchscreen which might add to the problems, though Linux handles it without much issue.)
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 8,057
Messages: 31,638

Are you saying that Haswell should be supported? Because it doesn't seem to be, though I haven't tried with 11.1-RC. Definitely wasn't working on 11.0 on a yoga 2.
According to the Wiki, yes.

https://wiki.freebsd.org/Graphics#Intel_Graphics

Although I haven't tested it myself, I don't have the equipment. All my machines either run console only or have an NVidia card.
 

scottro

Daemon

Reaction score: 526
Messages: 1,458

I believe it's incorrect, then, but I only have one machine with a Haswell or later, the aforementioned yoga2. These days (no insult to anyone, there simply isn't enough manpower) much of the FreeBSD documentation gets scattered between wiki and handbook and often seems out of date. That mention of Haswell gives a link to another page, about an older drm-next, (from around March of last year) that never worked for me.
https://wiki.freebsd.org/Graphics/Update i915 GPU driver to Linux 3.8
To the OP, you can try that link, but the last listing of status I see is that it was in HEAD (CURRENT). If you do try it, please put the results here, I'd be curious.

I do suspect that Haswell is not going to work with a standard FreeBSD-11 install, but can only say that it doesn't work with FreeBSD-11 on a Yoga2 Pro using a Haswell card.

Also at the bottom of the page they list known issues with Haswell, and that some have had my results, nothing but a blank screen.
 
Top