Solved Installing 9.0-RELEASE: Mounting DVD failed with error 19

Hi guys,

This is my first post in an English-speaking [Free]BSD community and I'm really excited and happy to join it :)
I'd have loved to start with a more positive post, but unfortunately this one has to deal with an installation issue.

Context:
I've just got a new dedicated server (my first one), ordered from a French hosting provider that doesn't offer any FreeBSD installation services (I don't mind, I prefer to do things myself). I gave them a link so they can download the installation ISO file, burn it and put it in a DVD drive that would be plugged to the server.
I now have a KVM over IP access so I can proceed with the installation.

For your information, the target machine is a dedicated server with:
  • Intel Xeon 3000
  • 4GB of RAM
  • 250 GB hard-drive

I chose to install the FreeBSD 9.0-RELEASE amd64 version as I wanted to try out the new BSDInstall. I gave the hosting provider the link to download the FreeBSD-9.0-RELEASE-amd64-dvd1.iso file.

Issue:
Here is the error message that I've got:
Code:
cd0 at umass-sim0 bus 0 scbus3 target 0 lun 0
cd0: <ASUS SDRW-08D2S-U B302> Removable CD-ROM SCSI-0 device
cd0: 40.000MB/s transfers
cd0: cd present [1166275 x 2048 byte records]
Mounting from cd9660:/dev/iso9660/FREEBSD_INSTALL failed with error 19.

Loader variables:
    vfs.root.mountfrom=cd9660:/dev/iso9660/FREEBSD_INSTALL
    vfs.root.mountfrom.option=ro

Manual root filesystem specification:
    <fstype>:<device> [option]
        Mount <device> using filesystem <fstype>
        and with the specified (optional) option list.

    eg. ufs:/dev/da0s1a
        zf:tank

The system seems to recognize the DVD drive but is unable to mount the media correctly.

Ideas & link (so far):
I've done some research and this problem is relatively common with the 9.0-RELEASE:
In these threads, most people are having this issue during an upgrade. They can troubleshoot using their currently installed system. I can't.

Some folks suggest to use the disc1.iso or the bootonly.iso or even some but as I said I don't have physical access to the server. It doesn't seem to solve the problem everytime. Moreover, I can only ask the provider to burn an ISO, put it in a DVD drive and plug it to the server. Each time I'd asked them to do such an action, I'd been charged with installation fees so I cannot easily try anything without been pretty sure of the result before.

So I posted here to see if you may have some ideas or suggestions. I'll keep investigating.

Thanks
 

wblock@

Developer
@mindjack, that is likely a different problem. USB devices sometimes take a few seconds to become available after boot. Just retrying them after a delay is often enough to make them work.
 
Last edited by a moderator:
I had the same problem when installing version 10 from CD, but
Code:
mountroot> cd9660:/dev/cd0
also worked for me. Thanks
 
Top