Installing 10.X from Memstick doesn't work, but 9.X works.

Zorquan

New Member


Messages: 6

Hi FreeBSD Community,

I wanted to install FreeBSD on my old PC, just to play around a little, and maybe write some software for it, just for the fun of it. I'm nowhere near a proffesional, so please have mercy on me. And patience, lots of patience.

Anyway, first I installed FreeBSD 9.2, via a memstick image, which worked like a charm. Only problem is, my Realtek 8188 wireless card was not supported on that version. I found some patches for the source in this forum that might or might not work, but as I'm not experienced at all, I really don't want to compile a patched FreeBSD version from source on day 1.
So I decided to use FreeBSD 10.4 instead. When I try to boot from the usb stick, there is a brief flash of some "Checksum Error" (I can't read it fully, it's only there for a split second) and the screen goes black. Then the (still installed) FreeBSD 9.2 boots. I tried 10.2 as well, same problem. I checked the checksums, the image is definitely fine. There is no real error message or anything, it just doesn't want to boot the stick. I even tried different USB sticks.

Is there something new in the 10.X memstick images that lead to this error?
My PC is some old Medion PC with a Intel Pentium Duo T4500 processor, if that is of any use. Oh, and I burned the img via the Rufus tool. But I also used it for the 9.2 version, so that should be fine, shouldn't it?

Cheers and thanks for the help,
Zorquan.
 

k.jacker

Aspiring Daemon

Reaction score: 428
Messages: 736

And patience, lots of patience.
Thanks for the warning :D

...brief flash of some "Checksum Error" (I can't read it fully, it's only there for a split second) and the screen goes black. Then the (still installed) FreeBSD 9.2 boots.
That sounds like you haven't actually booted into FreeBSD 10.4, but this Checksum Error appears in the POST messages of the BIOS.
New, to the 10.4-RELEASE compared to 9.2 is UEFI booting support, which your computer doesn't support, because of it's age. That's not a problem since installer won't install UEFI bootcode anyway, when the usb stick is booted in legacy mode.

The common Realtek RTL8188CE is supported by the rtwn(4) driver, no need for patching anything by hand. But there is also a (rare I think) RTL8188EE that isn't supported yet.

Forget about FreeBSD 9.x it has been End of Life for years, stick with FreeBSD 10.4.

Do you have any important data on your hdd, or is it just the fresh installs of 9.2 and 10.4?
If not, try again and let the 10.4-RELEASE installer use the whole disk and wipe FreeBSD 9.2.

Should you then still have any problems with booting into FreeBSD 10.4-RELEASE, please post here again.
 
OP
OP
Z

Zorquan

New Member


Messages: 6

Thank you for your help!

If not, try again and let the 10.4-RELEASE installer use the whole disk and wipe FreeBSD 9.2.
Unfortunately, the installer of 10.4-RELEASE doesn't even show up. When I try to boot from the usb stick, nothing happens (except the brief checksum error). Then, FreeBSD 9.2 starts. So 9.2 is the only thing installed on the HDD. I can't even boot the installer of 10.4-RELEASE.

I have tried different USB sticks, and different 10.X versions, same problem. On 9.X versions, however, the installer boots just fine.
 

k.jacker

Aspiring Daemon

Reaction score: 428
Messages: 736

Can you enter the computer's BIOS and set the boot sequence to boot from USB first. Now that you have one working OS installed on the hdd it will probably not look for bootable USB devices.
You could try to load the BIOS's default as well and try again. And finally there is also FreeBSD 11.2-RELEASE which you could try.

Since your computer is about 10 years old, the checksum error could be indicating the battery on the motherboard needs to be replaced.
Usually a CR2032 3V, should be easy to swap out. Disconnect from power supply first.
 
OP
OP
Z

Zorquan

New Member


Messages: 6

Yes, I have set the boot sequence to USB first. It just doesn't want to boot the 10.X release installer. I just tried 11.1, same result.

I select "boot from USB" and there's a brief flash of "primary gpt checksum mismatch", then FreeBSD 9.2 boots from the hdd.

But when I put the FreeBSD 9.2 img on the usb stick, it boots the installer just fine, from the same usb stick. Any suggestions? Or is the computer just too old?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 8,000
Messages: 31,432

It might have problems with GPT, if I recall correctly FreeBSD 9 still used the old MBR partitioning. I suspect your BIOS just doesn't know how to handle GPT correctly.

But all is not lost. Have you tried FreeBSD 9.3? If not, just do the install with 9.2 and use freebsd-update(8) to update it to 10.4.
 
OP
OP
Z

Zorquan

New Member


Messages: 6

But all is not lost. Have you tried FreeBSD 9.3? If not, just do the install with 9.2 and use freebsd-update(8) to update it to 10.4.
I will try FreeBSD 9.3.
However, the reason why I tried a newer release in the first place, is because I can't get my wireless card to work on FreeBSD 9.2. I've searched on this forum and the best I found is upgrading to a newer version.

Here's the problem:
typing ifconfig gives:
Code:
#ifconfig
re0: flags-8802CBROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options-8209b <RXCSUM, TXCSUM, ULAN MTU, ULAN HWTAGGING, ULAN HWCSUM, WOL MAG
    C,LINKSTATE>
    ether 00:26:2d:22:2c+43
    nd6 options-29(PERFORMNUD, IFDISABLED,AUTO-LINKLOCAL>
    media: Ethernet autoselect (10baseT>UTP ha lf-duplex))
    status: no carrier
lo0: flags-8049くUP , LOOPBACK , RUNNING , MULTICAST> metric 0 mtu 16384
    options-600003< RXCSUM, TXCSUM, RXCSUM-I PU6 , TXCSUM-İPU6>
    inet6 ::1 pref ixlen 128
    inet6 fe80: :1xlo0 pref ixlen 64 scopeid Oxa
    inet 127.0.0.1 netmask 0xf f 000000
    nd6 options 21 <PERFORMNUD, AUTO LINKLOCAL>
So as I understand it, re0 is my LAN card, which is up and ready, but I don't have LAN access to my router.
Typing pciconf -lv gives me (cut):

Code:
none2@pci0:4:0:0: class 0x028000 card 0x817210ec chip-0x817210ec rev-0x10
hdr=0x00
    vendor    = Realtek Semiconductor Co., Ltd.
    device    = RTL8191SEvB Wireless LAN Controller
    class    = network
re0@pci0:7:0:0: class-oxoz0000 card-0x10d017c0 chip-ox816810ec rev-oxe3 hdr-0xe0
    vendor    = Realtek Semiconductor Co. , Ltd.'
    device    = RTL8 1 1 1/8168B PCI Express Gigabit Ethernet controller
    class    = network
    subclass = ethernet
So, again as I understand it re0 is my ethernet card which is working just fine. But my wireless card is not recognized by FreeBSD. So as I don't have access to the Internet, naturally I can't update the system this way. (And actually I just want one working version, which one is not important :D)
 

k.jacker

Aspiring Daemon

Reaction score: 428
Messages: 736

You have to update anyway.
I would do as SirDice said, if you can't boot into the newer releases.
Update to 10.4-RELEASE, that release is still supported, because 9.2 has been End of Life since 2013.

Check the Handbook to learn how to update FreeBSD.
Your wireless lan seems to be a Realtek RTL8191SEvB, not RTL8188. The driver that could support it is the rsu(4) which supports the RTL8191SU (quite close to to yours, though no guarantee it works. Realtek is not good).
 
OP
OP
Z

Zorquan

New Member


Messages: 6

Thank you for the help!
I've checked the handbook and I'll try to update my running 9.2 version to 10.4 from source. Hopefully my internet will work then, I'll see.

The easiest option would've been to just invest some bucks into another, equally old but better supported wireless card. But sadly, I cannot open that PC without breaking the case, thanks Medion...
 

k.jacker

Aspiring Daemon

Reaction score: 428
Messages: 736

You can buy a USB wireless device.

Isn't there any chance you could just throw a cable onto the flour and use ethernet for updating.
Updating via wireless isn't really fun.
 
OP
OP
Z

Zorquan

New Member


Messages: 6

The wireless usb device is a brilliant idea, didn't even think of that.
Well, my PC is on 1. floor (one above the ground, I'm always confused how to count floors in english) and the router is in the basement which I don't have access to. So I guess update via wireless usb device is my best guess.
 

rraj

Member

Reaction score: 4
Messages: 60

Hi

I am facing similar problem with Free BSD 11.2, I have already set the boot sequence to boot from USB!

Thanks
Ravi
 

rraj

Member

Reaction score: 4
Messages: 60

Hi

In reference to my post above, the error i receive is:

failed to load '/boot/loader.efi'

panic: No bootable partition found!


Thanks
Ravi
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 8,000
Messages: 31,432

You're trying to UEFI boot a system that doesn't have an efi partition. Turn on CSM booting in the BIOS/UEFI.
 
Top