Installed FreeBSD13 but doesnt show up in UEFI options

After using Linux for several years, I decided to install FreeBSD. However, my system seems to be unable to detect the installed boot loader.

efibootmgr shows that the boot loaderfile is "null", is that relevant?

My boot loader is in /dev/ada0p1/EFI/BOOT/BOOTx64.EFI

I booted with a live USB linux mint os to use the following command to set up my bootloader:
Code:
$ mount /dev/sda1 /mnt && cd /mnt
$ efibootmgr -c -d /dev/sda -p 1 -l \\EFI\\BOOT\\BOOTx64.EFI -L FreeBSD
$ efibootmgr -b 0000 -a

I'm using a x86-64 Samsung machine that originally ran windows and several linux distros. I also tried mounting with both zfs and ufs file systems to not avail.

Some relevant links, none of which could fully resolve my issue:



 

Attachments

  • 1622274204121.jpg
    1622274204121.jpg
    412.4 KB · Views: 235
Code:
efibootmgr -c -d /dev/sda -p 1 -l \\EFI\\BOOT\\BOOTx64.EFI -L FreeBSD
Why are you using backslashes here? And using a Linux disk reference?
efibootmgr -a -c -l /mnt/EFI/boot/bootx64.EFI -L FreeBSD-13

Note that if you only have /EFI/BOOT/BOOTx64.EFI you don't have to configure anything. This is the default file UEFI will try to load. See uefi(8).
 
On some early UEFI systems (e.g. 2011-2013), there may not be a boot manager. It may just blindly boot /EFI/boot/bootx64.EFI as the bootloader.

One thing you can do is:

Code:
 # mount_msdosfs /dev/ada0p1 /mnt # Replace /dev/ada0p1 with the disk/EFI partition
 # cd /mnt/EFI/BOOT
 # ls

If you don't see BOOTX64.EFI

Code:
# cp /boot/loader.efi BOOTX64.EFI # Do if you don't see BOOTX64.EFI
 
This is mostly over my head. If I can help at all, it might be only to note that gustring is using /dev/sda as a hard drive reference because he is not running FreeBSD at all, but rather, he is running a linux OS, from a Linux Mint live installer on a USB pendrive. Otherwise I'm not familiar with these commands and have never tried to do things this way.
 
Back
Top