Solved Installation on a Dell XPS 7390 2-in-1, freeze and panic during install

b_one

New Member

Reaction score: 1
Messages: 2

Hi here,

I got my hand on a Dell XPS 7390 2-in-1 and I want to try to FreeBSD on it. I know this is a fairly new laptop and not everything might work, but I want to give it a try anyway.

I tried first the memstick of FreeBSD 13.0, but the kernel could not be loaded (it got hang just after the bootloader). I tried the safe mode as well, but I got the same results.

Thinking this might have been fixed in a newer version, I tried the last memstick image (CURRENT). This image managed to load the kernel, but it got another issue: it could not find the root partition and resulted in a kernel panic. I attached a screenshot of where the panic happens.

Is there anyway I can fix that in either FreeBSD 13.0 or CURRENT?

Any help will be greatly appreciated!
 

Attachments

  • photo1634116534.jpeg
    photo1634116534.jpeg
    267.7 KB · Views: 9

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,331
Messages: 38,847

That /: bad dir ino 7 at offset 0: mangled entry doesn't look good. Have you tried a different USB stick? It looks like this one might be corrupted. Also verify the hash of the image before writing it to make sure the image itself downloaded correctly.
 

pebkac

New Member

Reaction score: 9
Messages: 19

I use a 7390 happily as my daily driver notebook with FreeBSD 13 (and before 12.2) for roughly a year now and everything that I need works really well and overall it is rock stable.

I did not yet manage to set up suspend, webcam does not work and I use WIFI via net/wifibox (before I simply used a USB WIFI dongle) and I don't know yet how to set up the touchscreen (under sway/wayland). The SD card reader seems to work though.

There are a few things I needed to figure out at first though, e.g. select the correct timer chip (otherwise the clock was always about 50% too slow) via sysctl.conf:

Code:
kern.timecounter.hardware=HPET

So if you run into any problems, feel free to ask. Maybe I already figured it out. :)
 
Top