Install freezes at Consoles: EFI Consoles

dcol

Member

Reaction score: 1
Messages: 20

Using UEFI, I cannot install FreeBSD which hangs on the message 'Consoles: EFI Consoles'
I am using the latest FreeBSD 11 memstick image. System is a Dell Optiplex 7010. I have many of these systems and have only been able to boot using a 7010 desktop with no NIC's installed. As soon as I install a NIC, the install boot freezes. Now I have many other Dell Optiplex systems 3010,7010,9010 which are all SFF and all of them freeze on the install with or without a NIC installed.
BIOS is the latest, Legacy mode disabled, secure boot disabled, using all default BIOS settings.

Question is. why does it hang on 'Consoles: EFI Consoles'?
What is it looking for?

This is all I get in an install boot
>> FreeBSD EFI boot block
Loader path: /boot/loader.efi

Initializing modules: ZFS UFS
Probing 7 block devices.......*... done
ZFS found no pools
UFS found 1 partituion
Consoles: EFI Consoles <Freezes here
 

Phishfry

Son of Beastie

Reaction score: 2,035
Messages: 4,998

Have you tried the i386 USB memstick install? Some machines with UEFI problem firmwares will boot in 32bit mode as it has no EFI booting.

You could also consider reverting to the old console called sc(4) by using the loader:
set kern.vty=sc
boot
 

Phishfry

Son of Beastie

Reaction score: 2,035
Messages: 4,998

why does it hang on 'Consoles: EFI Consoles'?
What is it looking for?
The next step in the boot sequence is vt_vga which is where your problem is. Some of the things you can try at the loader prompt is set gop 0 or maybe set mode 0 perhaps set mode 3
There are others if you look around.
To get to loader press #3 at the Beastie Logo --Escape to loader prompt--
If none of these work then try sc and if that don't work try 32bit install.
 
OP
D

dcol

Member

Reaction score: 1
Messages: 20

Thanks for your reply. I never get to the Beastie Logo so I cannot enter those commands. The freeze happens just before the logo appears. I did try a different video card AMD R7-240 which supports UEFI with no change. Now the strange thing is I can get it to boot on the 7010 desktop if I do the following
Load Default settings
Disable Legacy option ROMs
Disable PXE
But as soon as I install an Intel i340-T4 NIC, it goes back to freezing. Other strange thing is, on the 7010 SFF even if I do the BIOS settings, it always freezes. I have never been able to boot an SFF models 3010, 7010, or 9010.
I have disabled the PXE boot on the Intel NIC with no change.
I even tried Freebsd version 12, still freezes

So my next question is. Is there a way to make changes to the boot loader before it boots by changing a file? It doesn't seem the USB memstick is readable in Windows. Must be an incompatible file system
 
Last edited:

Phishfry

Son of Beastie

Reaction score: 2,035
Messages: 4,998

If you have no FreeBSD install to mount the Memstick installer you would use a second USB thumbstick. So boot off one USB Memstick into the shell and edit the contents of the second USB Memstick installer after you mount it.
Keep in mind the partition you want to mount will not be the first partition as the first is EFI.
You will need to make use of gpart show da1 to find your freebsd-ufs partition.
For example:
mount /dev/da1p2 /mnt
da1=assumes second USB drive
p2=assumes second partition is your freebsd-ufs

Once you get it mounted you can edit the files like normal from the shell.
The editor ee is included for easy editing.

/boot/loader.conf is not included in the install so you must create one:
ee /mnt/boot/loader.conf

Then try your different video tunables(mode 0, mode 3, gop 0) and see what you can get to work.

Maybe the BIOS OptionROM is conflicting with the Intel cards.
 
OP
D

dcol

Member

Reaction score: 1
Messages: 20

Ok, used the two stick method and the freebsd-ufs was p3. I booted FreeBSD in legacy mode and made the changes to loader.conf in da1.
Tried all the tunables and it still freezes booting with UEFI . In the meantime, I tried a Ubuntu UEFI install and it worked fine. The only install that doesn't seem to work in UEFI mode is FreeBSD, so that has to be a bug or an oversight.

I also did 'vidcontrol -i mode' and it showed nothing in the listing. So what can I try now? Seeing I can now edit the files on the install stick.
 

Phishfry

Son of Beastie

Reaction score: 2,035
Messages: 4,998

I have some embedded boards that won't boot off amd64 but will with i386 install.

The key to getting them to do a amd64 Legacy BIOS install is via the bios I have to manually tell it to use the PMAP Legacy-USB and Not UEFI-USB Boot for the usb device. FreeBSD installer can actually boot in either mode and the bios chooses which to use.
Some boards you can choose this from a keyboard menu on startup like F12. Some you have a Boot override on the last screen in the BIOS where you direct the USB disk drive.

I am afraid with a Dell your BIOS options are probably much more limited.
 
OP
D

dcol

Member

Reaction score: 1
Messages: 20

still freezes with 'set kern.vty=sc' I also had 'set gop 0' in there
It doesn't matter if I use a USB memstick or a CD install. Still freezes.
Dell has many options for booting in Legacy or UEFI mode and every other OS install works fine in UEFI mode except FreeBSD.
 
OP
D

dcol

Member

Reaction score: 1
Messages: 20

Spent time using other distro's and they all installed in UEFI mode. Tried LinuxMint, Ubuntu, debian, Windows 7, Windows 10. FreeBSD is the only one that freezes. I need FreeBSD because the ultimate goal is pfsense, so I do not have a choice.
 
OP
D

dcol

Member

Reaction score: 1
Messages: 20

So the next thing I tried was to install pfsense under legacy mode and choose ZFS with GPT/UEFI partitioning.
Install competed, but it freezes on booting at the same place 'Consoles: EFI Consoles'

HELP!
 
OP
D

dcol

Member

Reaction score: 1
Messages: 20

At this point I can only assume this is a FreeBSD bug so I submitted a bug report Bug#219957
 
OP
D

dcol

Member

Reaction score: 1
Messages: 20

No go. 9.1 also freezes on 'Consoles: EFI Console'
FreeBSD install freezes with UEFI mode on some computers. Does not affect enough systems for the devs to fix it.
Works fine in Legacy mode. FreeBSD is the only distro that does this.
This is on a Dell 9010. Tried an HP 6300, which is the same vintage and same CPU, and FreeBSD installs fine in UEFI mode.
Yes I know this is a BIOS issue and Dell just released a new BIOS A29 as of March1st 2018 and the issue is still there. But every other flavor of Linux and Windows doesn't have this issue which means it could be fixed. There is something that FreeBSD is waiting for during a UEFI boot in which the Dell never responds to. And it isn't a video issue either since I tried other UEFI compatible video cards.
There is a manual workaround. If you enable legacy mode, but use F12 and choose the UEFI disk from the boot menu, it boots in UEFI mode. Once you setup the OS that way you have to manually boot from the boot menu or it will not work.
 

trev

Aspiring Daemon

Reaction score: 224
Messages: 934

If you used a 9.1-R amd64 disc there is no UEFI involved... so I'm guessing you used the wrong disc image. UEFI showed up in 10.1-R.
 
OP
D

dcol

Member

Reaction score: 1
Messages: 20

Not the point. 9.1 did the same thing as all the other FreeBSD images that are suppose to support UEFI, doesn't work on all systems.
I even tried 12.0.
I am not even implying it is a bug, just an incompatibility issue. FreeBSD is not UEFI compatible with all UEFI based computers.
 

trev

Aspiring Daemon

Reaction score: 224
Messages: 934

If I undertstand your response, the problem is not UEFI but something else (as 9.1-R does not do UEFI and still fails the same way).
 

La_Bela

New Member


Messages: 3

I have the same issue with the latest pfsense build. Will try the current TrueOS. Any chance it will get a fix?
 

La_Bela

New Member


Messages: 3


Thanks,

Also tried now with FreeBSD-11.2-RELEASE-amd64-memstick with no luck. If I disable UEFI boot, and go with legacy BIOS, I can install it. it is a Dell Optiplex 7010 with the latest Dell Optiplex A28 BIOS. [USER=52837]dcol[/USER] mentioned he/she found A29 BIOS but I couldn't find it. Also I tried to install freebsd on an HP Compaq Elite 8300 with UEFI turned on, and it went absolutely flawless. By the way, on the Optiplex 7010 I can install Windows 10 ENTERPRISE 1803 or Ubuntu 18.04 LTS in UEFI mode without any problem.

So should I give it up?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 9,376
Messages: 33,972

If UEFI booting is giving you problems why don't you stick to the traditional CSM boot?
 

La_Bela

New Member


Messages: 3

If UEFI booting is giving you problems why don't you stick to the traditional CSM boot?

I will. Because nothing seems to work... Just wondering, if these "decommissioned" office machines (actually 8) were running Windows 8.1 and after 10 ENT for years, now could serve some basic stuff, in our network monitoring project was able to run OSes in UEFI, why freebsd is not able to do the same. It's not a problem, surely we will configure it to legacy bios and use it that way.

thanks
 
Top